SCS Software

message board
It is currently 25 Oct 2014 07:32

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 30 posts ]  Go to page 1, 2, 3  Next
Author Message
PostPosted: 11 Apr 2013 12:28 
Offline
Site Admin

Joined: 24 Nov 2012 23:42
Posts: 8
ETS2 does not work on MESA, currently this means that even Intel 3000/4000 chipsets which are fine on Windows won't work. The game only works on native Nvidia and AMD drivers

Crashes when deleting Player Profile

No support for MP3 format - will need to identify suitable library and get an MP3 license

Mouse control lost after grahipics setting change (actually loss of focus for the app)


Top
 Profile  
 
PostPosted: 11 Apr 2013 12:40 
Offline

Joined: 11 Apr 2013 12:03
Posts: 7
I have tried the game on Intel HD3000, and the game runs smoothly. The problem is some flickering and missing light (its always like dawn, with no sun) except in the virtual mirrors (full light as it should be).
The first time I tried changing graphics, as you said, mouse lost the focus. I closed the game, changed the graphics, and no losing focus this time.
Screenshots also weren't working because of the light problem (2 od 10 came out good, others just rgb colors).
Will try on Ati and Nvidia later.


Top
 Profile  
 
PostPosted: 11 Apr 2013 13:39 
Offline

Joined: 11 Apr 2013 13:12
Posts: 25
Would there be any plan to support flacc audio files as well?


Top
 Profile  
 
PostPosted: 11 Apr 2013 16:00 
Offline

Joined: 20 Feb 2013 18:27
Posts: 27
blacx wrote:
I have tried the game on Intel HD3000, and the game runs smoothly. The problem is some flickering and missing light (its always like dawn, with no sun) except in the virtual mirrors (full light as it should be).
The first time I tried changing graphics, as you said, mouse lost the focus. I closed the game, changed the graphics, and no losing focus this time.
Screenshots also weren't working because of the light problem (2 od 10 came out good, others just rgb colors).
Will try on Ati and Nvidia later.



I've tried the game on an intel hd 3000 on both mesa 8.0.4 and mesa 9.1.1 and in both cases the game runs as in it starts I can hear the sounds but it shows only a black screen, I don't currently have any other video cards where I can try it on so for now this is a showstopper for me. :( What are the plans to fix mesa support?


Top
 Profile  
 
PostPosted: 11 Apr 2013 16:22 
Offline

Joined: 11 Apr 2013 13:13
Posts: 9
Seems you listed all the issues I found already although: Crashes when deleting Player Profile

That bug actually ruined all my settings when i deleted a profile, so screen resolution and everything got totally reset. My screen res for some reason defaulted to 1024x768 :/


Top
 Profile  
 
PostPosted: 11 Apr 2013 17:00 
Offline

Joined: 11 Apr 2013 15:38
Posts: 2
I lost mouse control after graphics settings change, but you have this already.

Else one, at night asphalt is the same as was in the day (unnaturally bright). It's issue with lights?

This occurs on Ubuntu 12.10 (ATI HD5000, Catalyst 13.1), but on Ubuntu 12.10 with Nvidia 8600GT (and Steam recommended drivers) doesn't.


Top
 Profile  
 
PostPosted: 12 Apr 2013 10:34 
Offline

Joined: 12 Apr 2013 06:08
Posts: 13
Pavel wrote:
No support for MP3 format - will need to identify suitable library and get an MP3 license

I'm curious about this, is the Windows solution to use one of the system libraries that has an MP3 license? I think you should be able to do this with Ubuntu too. SDL_mixer can dynamically load the system library providing support for MP3 decoding, but I suppose it would be slightly nicer to include the MP3 library with the game (requiring a license).

Another option could be using gstreamer, since it seems to be largely for media playback support in the game (radio/music folder). Phonon, the other common media framework, supports the gstreamer API, so that covers almost all Linux desktops.


Top
 Profile  
 
PostPosted: 12 Apr 2013 11:25 
Offline
User avatar

Joined: 26 Nov 2012 11:22
Posts: 227
chizu wrote:
I'm curious about this, is the Windows solution to use one of the system libraries that has an MP3 license?


Yes. We tell the DirectShow API that it should play the URL or file and it will try to use whatever filters are registered in the system (demultiplexers, decoders, output renderers) to do it. As many media programs install theirs own filters of dubious quality and many people also install various codec packs, this might get somewhat messy or even crash the game however it works most of the time.


Top
 Profile  
 
PostPosted: 12 Apr 2013 15:25 
Offline

Joined: 11 Apr 2013 17:32
Posts: 3
Everything works fine for me so far. Except the radio stations. Not sure if that's related to the MP3 codec problem or not.

_________________
Fedora 17 64bit - AMD FX 8350 Cpu
8gigs 1800 ram - Nvidia GTX660ti


Top
 Profile  
 
PostPosted: 12 Apr 2013 16:53 
Offline
User avatar

Joined: 11 Apr 2013 14:02
Posts: 21
Have you tried contacting Fluendo? http://www.fluendo.com/

We at Fuduntu got the license for free, but I don't know if they'll provide it for free for a commercial product though.

_________________
Toshiba L650-1HM - Intel Core i3 370M (2.40GHZ), ATI Radeon Mobility HD 5650 FGLRX 13.4 (dual-monitor 2732x768), 8GB DDR3 RAM, Dual OCZ Vertex 3 SSDs, Fuduntu 2013.2 32bit (Linux 3.8.5-1.fu2013.i686.PAE Kernel) KDE 4.10.2


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 30 posts ]  Go to page 1, 2, 3  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: