SCS Software

message board
It is currently 26 Mar 2017 20:49

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 40 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
PostPosted: 29 Jul 2016 11:57 
Offline

Joined: 29 Jul 2016 11:44
Posts: 2
Today, i have try to connect my game (EuroTruckSimulator2) with an WorldOfTruck Account, i have give the product key but he said: THE SPECIFIED SERIAL CODE IS INVALID OR ALREADY ASSOCIATED WITH AN EXISTING ACCOUNT.. Now who create an worldoftruck account ?!
Thank for you'r replied

(If my language is bad, i'm sorry, i am frensh)




Moderator note:
Due to the sudden influx of "WoT e-mail verification problems" posts and threads, and all these "new user accounts" that are springing up reporting this problem, instead of having to constantly research IP addresses to weed out the duplicate multiple accounts I'm just going to throw all the e-mail verification posts together in here now instead!


Last edited by Reef on 31 Jul 2016 01:03, edited 4 times in total.
Attachment removed - redundant. - ohaha. [merged into existing topic - Reef]


Top
 Profile  
 
PostPosted: 29 Jul 2016 18:03 
Offline

Joined: 29 Jul 2016 17:42
Posts: 2
I've got problem...I registered 1 hour ago and I still haven't got verification mail. What should I do?
Thanks


Last edited by Reef on 31 Jul 2016 01:03, edited 1 time in total.
merged into existing topic


Top
 Profile  
 
 Post subject: E-mails not coming in
PostPosted: 29 Jul 2016 18:11 
Offline

Joined: 29 Jul 2016 18:08
Posts: 1
When you register for a WoT account, you never get the activation mail.
I've checked my spam folder and my inbox multiple times and it's just not being sent.

Also, my ETS2 is apparently already associated with another existing account, I have a slight idea what account it is, but when recovering password, I also don't get an e-mail.

Please fix this, it seems as though a lot of people are having problems with this and none have been replied to as of yet.


Last edited by Reef on 31 Jul 2016 00:47, edited 1 time in total.
merged into existing topic


Top
 Profile  
 
 Post subject: Re: VERIFICATION EMAIL
PostPosted: 29 Jul 2016 18:28 
Online
User avatar

Joined: 05 Jul 2013 11:44
Posts: 5614
Location: Yorkshire
If you don't get the email within 24hrs it will drop the registration from the system so you can try again tomorrow.

Make sure to check your spam box.

_________________
My Blog/Mod page: http://ijsmods.wordpress.com
My WoT Profile
I reserve the right to be 100% wrong.
Image


Top
 Profile  
 
 Post subject: Re: VERIFICATION EMAIL
PostPosted: 30 Jul 2016 18:20 
Offline

Joined: 29 Jul 2016 17:42
Posts: 2
So I registered again and I don't have verification mail. I checked spam box and it's clear so dunno what to do.
Thanks


Top
 Profile  
 
 Post subject: veri e-mails
PostPosted: 30 Jul 2016 18:34 
Offline

Joined: 30 Jul 2016 18:30
Posts: 4
ok after reading this forum I can clearly see I'm not the only one that does not get the veri-emails when trying to make an account.

Rather than telling people to re-try in 24 hours - can you not simply fix the problem? after all when linking with a steam account or adding a product key - shouldn't that be enough to say that its a human making the account? why on earth do you have e-mail veri after doing a product veri when you clearly have some e-mail issues.

Cheers


Last edited by Reef on 31 Jul 2016 00:46, edited 1 time in total.
merged into existing topic


Top
 Profile  
 
PostPosted: 30 Jul 2016 18:53 
Offline

Joined: 30 Jul 2016 17:22
Posts: 1
I'm having the same problem. It's been over 24 hours also. I re-registered the new account and the same thing. No verification email is being sent out.


Top
 Profile  
 
PostPosted: 30 Jul 2016 22:22 
Offline

Joined: 30 Jul 2016 12:13
Posts: 2
I have the same problem still no email from them so annoying


Top
 Profile  
 
 Post subject: Re: veri e-mails
PostPosted: 30 Jul 2016 23:21 
Offline

Joined: 30 Jul 2016 23:19
Posts: 1
Yes, verification email NOT work.


Top
 Profile  
 
PostPosted: 30 Jul 2016 23:33 
Offline

Joined: 30 Jul 2016 18:30
Posts: 4
yea looks like we all have the same problem :(


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page 1, 2, 3, 4  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: