SCS Software

message board
It is currently 26 Mar 2017 18:51

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: 19 Mar 2017 01:00 
Offline
User avatar

Joined: 30 Jun 2015 03:56
Posts: 825
Location: Ontario, Canada
I'm having an interesting set of errors with a cargo accessory. It appears that the look and variant attributes of accessory_cargo_data don't properly apply to the detail_model attribute.

Errors:
Code:
00:00:35.301 : <ERROR> [model] Unknown look name '0' on model '/vehicle/trailer/scr_ut2000r_40_1988/fan.pmd'
00:00:35.302 : <ERROR> [model] Unknown variant name '0' on model '/vehicle/trailer/scr_ut2000r_40_1988/fan.pmd'


Related accessory_cargo_data:
Code:
SiiNunit
{
accessory_cargo_data : fan_40_88.ut2000r.scr.trailer.cargo
{
   detail_model:   "/vehicle/trailer/scr_ut2000r_40_1988/fan.pmd"
   model:      "/vehicle/trailer/scr_ut2000r_40_1988/fan_static.pmd"
   look: default
   variant: default
   animations[]: .idle.fan.anim
}

anim_idle : .idle.fan.anim
{
   animation: "/vehicle/trailer/scr_ut2000r_40_1988/fan.pma"
   time_offset: 0
}
}


I have also tried this using fan_static.pmd in the detail_model attribute and get the same errors.

I don't have this problem when I use either model in the model or lods attributes. This version produces no errors:
Code:
SiiNunit
{
accessory_cargo_data : fan_40_88.ut2000r.scr.trailer.cargo
{
   #detail_model:       "/vehicle/trailer/scr_ut2000r_40_1988/fan.pmd"
   model:          "/vehicle/trailer/scr_ut2000r_40_1988/fan.pmd"
   lods[]:         "/vehicle/trailer/scr_ut2000r_40_1988/fan_static.pmd"
   look: default
   variant: default
   animations[]: .idle.fan.anim
}

anim_idle : .idle.fan.anim
{
   animation: "/vehicle/trailer/scr_ut2000r_40_1988/fan.pma"
   time_offset: 0
}
}


Strangely enough, if I assign a detail_model to one of the flatbed cargos, no errors are generated. :?

_________________
Image
Current Projects | Roadmap | WoT


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: