ETS2/ATS Resolution Issues

Post Reply
ronsonk
Posts: 9
Joined: 12 Nov 2013 14:22
Location: Toronto, Ontario, Canada

ETS2/ATS Resolution Issues

#1 Post by ronsonk » 21 Nov 2020 14:49

I'm running Ubuntu 20.10 with a desktop resolution of 3840x2160 after an upgrade to a 4k monitor. Both ETS2/ATS had been running fine at 1080p fullscreen. Since the change of desktop resolution, I have not been able to run ETS2/ATS at fullscreen 1080p unless I set my desktop to 1080p before starting the game. If I don't, then ETS2/ATS will start, in a window, while scaling the desktop behind it (sort of like zooming in on the desktop), with title bars and other obstructions blocking some of the game screen. Exiting the game leaves me in this sort of zoomed-in desktop state, where I can scroll by moving the mouse off either side of the screen - I have to reset X in order to get back to normal.

I'm currently running the NVidia proprietary drivers. If anyone has any suggestions, they would be much appreciated.

skyking_eam
Posts: 5
Joined: 22 Apr 2020 20:20

Re: ETS2/ATS Resolution Issues

#2 Post by skyking_eam » 22 Nov 2020 15:11

Hello,

have you enabled scaling options in gnome display settings? If so, disable fractional scaling and set scale to 100 %

I tested it on my system and i had the same problem. I solved it by editing ~/.local/share/Euro Truck Simulator 2/config.cfg :

Code: Select all

uset r_fullscreen "0"
uset r_mode_height "1080"
uset r_mode_width "1920"
After that, ets2 should open in 1920x1080 windowed mode --> go to graphics settings and activate fullscreen mode --> restart game --> ets2 should now be starting in 1920x1080 fullscreen mode.

ronsonk
Posts: 9
Joined: 12 Nov 2013 14:22
Location: Toronto, Ontario, Canada

Re: ETS2/ATS Resolution Issues

#3 Post by ronsonk » 22 Nov 2020 23:08

I'm going to have to keep trying things and researching. It looks like a number of people had this problem with windowed displays back in 2016.

I changed config.sys to start windowed, started the game, went into graphics settings, clicked the radio button for Full Screen and then hit apply... black screen until the games counter realized I wasn't going to accept the changes and then it popped back in a window.

Thanks for your help though.

Post Reply

Return to “Linux Beta Testing”

Who is online

Users browsing this forum: No registered users and 1 guest