Emergency Vehicles not working in standalone country

Forum rules
SCS as a company do not wish to have paid mods on this forum. While we understand that not all paid mods use the Intellectual Property of other companies/people, it is very hard to moderate what is and isn't acceptable when money is involved. There are also concerns that it could look unfavorable to potential work partners going forward if SCS allow mods that may potentially use unlicensed branding.
Posting in the Mods forum (ATS and ETS2) is restricted to sharing free-to-the-public mods and providing support for mods. For more details, please check chapters [4] and [5] of Forum Rules.
Post Reply
fisherm
Posts: 6
Joined: 28 Apr 2020 15:55

Emergency Vehicles not working in standalone country

#1 Post by fisherm » 16 Aug 2020 15:35

Hi, I'm making a standalone map, and having trouble getting emergency vehicles or personnel to appear. I want to use the French services, so I copied France traffic, speed limits etc. into my def/country, but nothing appears when I try to place a new police vehicle. Existing vehicles in the map give me errors in the editor log like:

"00:00:34.595 : <ERROR> [mover_model_group_u::choose_desc] Cannot find country at the mover position: 2006.1;25.1;-1745.4
00:00:34.595 : <ERROR> [mover_instance_t::init] Cannot choose mover desc.
00:00:34.595 : <ERROR> [traffic] Vehicle data 'traffic.volvo_xc70.police' not allowed in country '(none)'
00:00:34.595 : <ERROR> [traffic] Allowed countries are: (none)
00:09:18.644 : <ERROR> [traffic] Error finding a traffic_vehicle data of type 'police' suitable for country: '(none)' custom filter
00:09:18.644 : <ERROR> [parked_vehicle] "No suitable vehicle model found!" [3335.1;30.1;-1571.8]

It feels like I'm being dumb and missing something like needing to add a country area in the same way as a city (otherwise, using only the co-ordinates for the map country label, how does a map know where the country borders are?), but in the dropdown selections, I haven't found add country. My trains aren't good at appearing either, but I'm hoping it's the same issue.

The game is seeing the custom country, at least partially, because the cities name it, and the job creation is working fine.

It's really bugging me, so any help would be really appreciated. I've tried copying all the def files from another custom country (the awesome Grand Utopia) but using them in my mod, still no police...

Thanks, fisherm

fisherm
Posts: 6
Joined: 28 Apr 2020 15:55

Re: Emergency Vehicles not working in standalone country

#2 Post by fisherm » 19 Aug 2020 11:15

Solved... You need to set a few nodes on roads as a border. That brings a dropdown menu to choose the country, and pick the standalone country forwards and backwards. Recompute the map, and we have police.

Post Reply

Return to “Help requests”

Who is online

Users browsing this forum: Baidu [Spider], tmrcardoso and 2 guests