Page 1 of 1

My plate won't update.

Posted: 18 Apr 2020 22:53
by Hslo
I had an Oregon plate set to 420 KFC. I changed it a week ago to Washington plate KDP8745. It has been a week as I said and no changes. Still 420 KFC Oregon. I made sure account was linked and everything was verified. It was, but it still won't change. I've even bought a new truck (I use a Lonestar Default)

Re: My plate won't update.

Posted: 19 Apr 2020 13:02
by Hslo
Still not updated. Just finished a complete install on a new profile with no mods.

Re: My plate won't update.

Posted: 20 Apr 2020 04:20
by donfede
Hello @Hslo

What are you trying to set your license plate to, and what are you seeing in game?
Glancing over your WoT profile (Badnut, linked from your SCS forum info), it looks like your ATS plate is set to "A38045E" Washington state.
Is that your intended plate or not?

If not, you can set the plate by logging into the WoT website, selecting My Page, then Profile Customization, and setting the plate and state you desire. Make sure to click the upload button. You should see the entered plate on your WoT Current Ride web page, and in game after restarting (or reentering the desired profile, which is linked to WoT).

Happy trucking

Re: My plate won't update.

Posted: 20 Apr 2020 11:25
by Hslo
Yes, that is correct. It works on the website, not ingame. And I did click upload. And every time I go to site, it has that plate.

Re: My plate won't update.

Posted: 20 Apr 2020 15:34
by Hslo
Guys, IG it was the PB. I didn’t know PB didn’t allow changes.

Re: My plate won't update.

Posted: 20 Apr 2020 21:46
by Madkine
The beta was linked to the beta version of WoT. (At least at the end.)

Re: My plate won't update.

Posted: 20 Apr 2020 22:52
by Hslo
Yeah, I didn’t know that lol