Turn signal sound bug

Post Reply
band1c
Posts: 27
Joined: 13 Oct 2013 09:31
Location: Perm, RU

Turn signal sound bug

#1 Post by band1c » 18 Oct 2014 19:02

One of sounds missing, then plays two times in a row. I met this few times driving New Volvo FH, can't confirm or refute it with other trucks.
game.log.txt

User avatar
Cadde
Posts: 9535
Joined: 24 Apr 2013 18:08
Location: Have no fear, i am from the internets!

Re: Turn signal sound bug

#2 Post by Cadde » 18 Oct 2014 21:02

Never had that happen before in this game but i have had sound skips like that in the past elsewhere. That was a hardware issue at the time.
Can you make it happen every time you turn hard left with the blinker in the Volvo?

Could you also post your controls.sii from your current profile? (Your profile folder is "62616E6431632D5350")
On extended hiatus.

User avatar
Baja_002
Posts: 2045
Joined: 08 Mar 2013 00:40
Location: Croatia

Re: Turn signal sound bug

#3 Post by Baja_002 » 18 Oct 2014 21:25

This does happen for me on keyboard (only from time to time); it's been like that for a long time. I guess the game gets a bit confused by the "violent" turning on keyboard.

User avatar
davidzoli
Posts: 3226
Joined: 22 Jun 2014 10:08
Location: Budapest, Hungary
Contact:

Re: Turn signal sound bug

#4 Post by davidzoli » 18 Oct 2014 21:45

I have the same sometimes when I turn the driver's head with mouse (and the game have to generate some new content quickly).
Try turning on console and watch if it happens during saving. Or try to turn on your warning sign and watch its continuity when you enter a city or when reach some hdd or cpu loader event.
It is like some little freeze but not in graphics.
Image

band1c
Posts: 27
Joined: 13 Oct 2013 09:31
Location: Perm, RU

Re: Turn signal sound bug

#5 Post by band1c » 19 Oct 2014 02:53

Cadde wrote:Can you make it happen every time you turn hard left with the blinker in the Volvo?
No, I can't.
Cadde wrote:Could you also post your controls.sii from your current profile? (Your profile folder is "62616E6431632D5350")
Here is controls.sii
davidzoli wrote:I have the same sometimes when I turn the driver's head with mouse (and the game have to generate some new content quickly).
It seems to be true.
davidzoli wrote:Try turning on console and watch if it happens during saving.
Ok, I'll try.
davidzoli wrote:Or try to turn on your warning sign and watch its continuity when you enter a city or when reach some hdd or cpu loader event.
I've tried this before for a few minutes but nothing interesting happened. Maybe longer time period needed. I understand your thought.

It looks like hardware issue indeed, not a game.

User avatar
Cadde
Posts: 9535
Joined: 24 Apr 2013 18:08
Location: Have no fear, i am from the internets!

Re: Turn signal sound bug

#6 Post by Cadde » 19 Oct 2014 05:36

Thanks, your controls.sii looks to be in order upon inspection but i cannot get mine to set the "c_hsauto" constant like yours. Don't get what that is for.
Either way, doesn't look like your blinkers are affected by turning your truck beyond the standard 27% limit.

That said, it could be that 27% limit that does it. Turn your blinkers on and turn your wheel 27% and then back a little and over 27% again and see if you can reproduce it that way.
I notice that your wheel turns slightly back (in the video) just at the time the blinker stops the sound and plays it twice.
On extended hiatus.

band1c
Posts: 27
Joined: 13 Oct 2013 09:31
Location: Perm, RU

Re: Turn signal sound bug

#7 Post by band1c » 19 Oct 2014 09:00

Cadde wrote:That said, it could be that 27% limit that does it. Turn your blinkers on and turn your wheel 27% and then back a little and over 27% again and see if you can reproduce it that way.
I notice that your wheel turns slightly back (in the video) just at the time the blinker stops the sound and plays it twice.
I've tried few times, but with no success.

BluB
Posts: 24
Joined: 26 Sep 2013 15:45
Contact:

Re: Turn signal sound bug

#8 Post by BluB » 19 Oct 2014 09:27

I've actually heard this happen a few times before too. And I've just tried turning my head really fast in a couple of trucks with the blinkers on and the sound does slow down/cut out for a bit. Could this be because the game is loading new models/textures or something?
I guess depending on your computers specs/graphics settings this could make it more or less noticeable?

User avatar
Max
SCS Software
Posts: 6119
Joined: 26 Nov 2012 10:00
Location: SCS, Prague

Re: Turn signal sound bug

#9 Post by Max » 20 Oct 2014 19:28

this is known issue and is fps related.
if your fps is (rather) low and in addition is varying wildly, timing does not work exactly and the difference is what you can hear as irregular sound. the interesting part is that optical signal is irregular by exactly same way but its not that easy to see ...
Nobody can tell you anything about it. Those who know about it aren't allowed to talk. And those who talk know nothing.

band1c
Posts: 27
Joined: 13 Oct 2013 09:31
Location: Perm, RU

Re: Turn signal sound bug

#10 Post by band1c » 20 Oct 2014 19:53

Max wrote:this is known issue and is fps related.
if your fps is (rather) low and in addition is varying wildly, timing does not work exactly and the difference is what you can hear as irregular sound. the interesting part is that optical signal is irregular by exactly same way but its not that easy to see ...
Thanks for the explanation.

Post Reply

Return to “Bugs 1.13”

Who is online

Users browsing this forum: No registered users and 1 guest