Auto Smooth error

Post Reply
User avatar
ONURKULL
Posts: 661
Joined: 19 Oct 2015 14:01
Location: Istanbul
Contact:

Auto Smooth error

#1 Post by ONURKULL » 18 Nov 2020 21:12

Hi everyone, i select "Auto Smooth" after Shade Smooth for save edges and looks perfect in render but object has looks only smooth in game. When i try import .pmd file and i see everytime object got "Custom Split Normals" everytime automatically. I little bit confused and i don't know what i should try :roll: (i tried remove doubles, triangulate faces etc.)

Does anyone have an idea for a solution ?

User avatar
MDModder
Posts: 892
Joined: 06 Nov 2015 07:00

Re: Auto Smooth error

#2 Post by MDModder » 19 Nov 2020 00:52

here is my technique, there is probably better, but it works

Addons YAVNE: viewtopic.php?t=275516

you have to triangulate (shortcut key ctrl + t ")

vidéo:

User avatar
ONURKULL
Posts: 661
Joined: 19 Oct 2015 14:01
Location: Istanbul
Contact:

Re: Auto Smooth error

#3 Post by ONURKULL » 19 Nov 2020 05:42

@MDModder Thanks but what is the reason is this error ? I made many other parts and i never see this error in them.

User avatar
MDModder
Posts: 892
Joined: 06 Nov 2015 07:00

Re: Auto Smooth error

#4 Post by MDModder » 19 Nov 2020 12:08

I don't know, my skills in this area are very limited :)

User avatar
AmirMahdavi
Posts: 163
Joined: 16 Feb 2017 13:03
Location: Gilan, Iran

Re: Auto Smooth error

#5 Post by AmirMahdavi » 22 Nov 2020 12:37

You can use the YAVNE addon or manually change smooth of mesh
BlenderTools support that smooth data and create a custom split normal to save it
but if you want to have sharp edge MUST use Edge Split modifier

(Blender 2.90)
For Auto splitting based on angle
1. Add Edge Split modifier
2. Check Edge Angle
3. And change the value as you want

For Manual split
1. Select edges you want to be sharp
2. Ctrl + E and click (Mark Sharp)
3. Add Edge Split modifier
4. Uncheck Edge Angle
5. Check Sharp Edges

And also you can combine them

I have this question too before and you can read it in viewtopic.php?t=275516
Yes, i have bad english :D

Post Reply

Return to “Blender Tools”

Who is online

Users browsing this forum: No registered users and 4 guests