Page 1 of 1

Auto Smooth error

Posted: 18 Nov 2020 21:12
by ONURKULL
Hi everyone, i select "Auto Smooth" after Shade Smooth for save edges and looks perfect in render but object has looks only smooth in game. When i try import .pmd file and i see everytime object got "Custom Split Normals" everytime automatically. I little bit confused and i don't know what i should try :roll: (i tried remove doubles, triangulate faces etc.)

Does anyone have an idea for a solution ?

Re: Auto Smooth error

Posted: 19 Nov 2020 00:52
by MDModder
here is my technique, there is probably better, but it works

Addons YAVNE: viewtopic.php?t=275516

you have to triangulate (shortcut key ctrl + t ")

vidéo:

Re: Auto Smooth error

Posted: 19 Nov 2020 05:42
by ONURKULL
@MDModder Thanks but what is the reason is this error ? I made many other parts and i never see this error in them.

Re: Auto Smooth error

Posted: 19 Nov 2020 12:08
by MDModder
I don't know, my skills in this area are very limited :)

Re: Auto Smooth error

Posted: 22 Nov 2020 12:37
by AmirMahdavi
You can use the YAVNE addon or manually change smooth of mesh
BlenderTools support that smooth data and create a custom split normal to save it
but if you want to have sharp edge MUST use Edge Split modifier

(Blender 2.90)
For Auto splitting based on angle
1. Add Edge Split modifier
2. Check Edge Angle
3. And change the value as you want

For Manual split
1. Select edges you want to be sharp
2. Ctrl + E and click (Mark Sharp)
3. Add Edge Split modifier
4. Uncheck Edge Angle
5. Check Sharp Edges

And also you can combine them

I have this question too before and you can read it in viewtopic.php?t=275516

Re: Auto Smooth error

Posted: 02 Dec 2020 09:58
by ONURKULL
@AmirMahdavi Thanks for all clarification Amir. I don't want use "Edge Split" because its add more more over verts. I have this error just for one part, auto smooth works perfectly in other parts therefore i think i will make a new model. Thanks again ;)