Page 1 of 1

Strange error

Posted: 03 Jan 2021 16:42
by RodriGM15

First of all, if this is not the right forum, please change it so it is correct :oops:

I have a problem that I hope someone could help me to solve. I am getting a game-crashing error after editing a trailer in blender. I've already read some more users with this error and the answer they get is about an outdated mod. But in this case, the mod has almost everything updated.

When I export in blender I have warnings because I added some flares from powerkasi's lightpack mod, so they get an expected hookup value warning, something that I get quite a lot and then in game there aren't errors.

It is true that it is a bit high-poly, but with my modification it has less polys and my PC has run heavier mods, so I think that shouldn't be the problem. The base I took is the D'Hoine Lamberet from Caspian Customs, edited only for private use, you can find it easily in google.

Also, I'd say that I edited a lot of things like this in blender, even with errors in game that didn't give me this problem, so I don't know what to do.

The exact error is this one
00:00:20.191 : <ERROR> d:\buildbot\slaves\win_slave\final_build_ets2_139_windows_bin_steam_x64\build\prism\src\p3core\collections\arrays\arrays_base_impl.h(491): ??A?$array_t@M@prism@@QEAAAEAM_K@Z: Index outside array boundaries.

Here's my full gamelog

If anything is missing, I can provide more info.

Thanks for reading

Re: Strange error

Posted: 03 Jan 2021 20:35
by Madkine
a) This file (or one it links to) is not defined correctly - /unit/hookup/vehicle_platel2.sii (in the sor iberica.scs mod)
b) This file is an old version (/model/flare/vehicle_redl.pmg), what version of blender are you using?

The error you posted is a fairly generic one, the other errors in the file are more useful in determining what's wrong.

Re: Strange error

Posted: 03 Jan 2021 21:14
by RodriGM15

First of all thanks for replying.

I use Blender 2.82 with the latest conversion tools.

About those two errors, I've alread fixed them, but the main error still happens. Here the new gamelog with the main error only.

If it is relevant, I talked with a friend of mine which also uses blender, and he gets the same error when he modifies a Caspian truck. He says that it happens only when he pastes parts from other models. Also we came to the conclusion that it has to be something related to blender, because other people has modified those mods in zmod whithout any problem

Re: Strange error

Posted: 03 Jan 2021 21:20
by xXCARL1992Xx
"because other people has modified those mods in zmod whithout any problem"

there is your problem, ZMod is no official tools from SCS, Blender Tools is, so if blender cries it means something was done that shouldnt have been done, the error you get has also nothing to do with anything 3D related, some mod tries to read data where it isnt supposed to, so some variable is outside of the games boundry, good luck finding that because it could be anything, from a wrong def to wrong flare definitions to wrong mod structure inside the defs

Re: (SOLVED) Strange error

Posted: 03 Jan 2021 21:29
by RodriGM15
Yes I know that mate.
The thing is that, I've reworked and created lots of mods without problems, with the same version of Blender and its tools.

This is the first time I get that exact error and it appears in a clean profile without any other mod, after a clean export, and with a mod base which worked without problems in the last version of the game.

I do everything as I've done before, but this time this happens. It is sure something related to that exact mod, but it seems impossible to figure out what it is.

Maybe it has something to do with the original trailer's defs, because it is true that the trailer is not made as SCS supposses ownables trailers to be made

Okey so I figured out what was happening. I was so silly :lol: I deleted by mistake a wheel locator, when I put another one where it was missing, everything goes right. Thanks Carl and Madnike for reading and trying to help.