SCS Blender Tools

User avatar
Ocedare
Posts: 537
Joined: 02 Feb 2018 16:46
Location: France

Re: SCS Blender Tools

#2211 Post by Ocedare » 19 May 2020 07:57

Hello everyone,

after having read a lot of interesting things but without having found a solution.
I will explain my problem to you.

Without my knowing why my installation of Blender stopped working. I didn't really know why it worked either ... :mrgreen:

So I did a new installation with Blender 2.82 installed in a folder at the root of my C drive.
Then dragged the BT version: 2.0.dd0ff0b folder into the addons folder of my Blender installation.

Image

I copied the base.scs and def.scs from the game, created a folder called "tempx" in my documents, pasted the .scs files and the tools to prepare my base.

I used scs extractor to decompress the two .scs files in the "tempx" folder.

Then I created a folder called "base" and dragged the files extracted by the extractor.

Finally I used converterPIX to get my "base_exp" folder.
I followed the instructions here: viewtopic.php?p=728908#p728908

Image

Then I activated BT in Blender and configured my workspace properties like this:

ProjectPath: "C:\Users\Xav\Documents\tempx\base_exp\"
ShaderPresetsFilePath: "C:\blender\2.82\scripts\addons\io_scs_tools\shader_presets.txt"
TriggerActionsRelFilePath: "C:\Users\Xav\Documents\tempx\base\def\world\trigger_action.sii"
SignRelFilePath: "C:\Users\Xav\Documents\tempx\base\def\world\sign.sii"
TSemProfileRelFilePath: "C:\Users\Xav\Documents\tempx\base\def\world\semaphore_profile.sii"
TrafficRulesRelFilePath: "C:\Users\Xav\Documents\tempx\base\def\world\traffic_rules.sii"
HookupRelDirPath: "//unit/hookup"
MatSubsRelFilePath: "C:\Users\Xav\Documents\tempx\base\material\material.db"
SunProfilesFilePath: "C:\Users\Xav\Documents\tempx\base\def\climate\default\nice.sii"
ConvertersPath: "C:\Users\Xav\Documents\tempx\conversion_tools_2_10\"

I copied a mod in my game folder and pasted it in my "tempx" folder then I used converterPIX to get an xx_exp folder in the "tempx" folder

I launch Blender and import the .pim file that I want to modify and I have an error message concerning the textures.
for exemple: ERROR - Can't find texture nor TOBJ inside SCS Project Base Path: '/vehicle/truck/kenworth_ford/crome2'

However, I have the .tobj file present in my xx_exp folder and the dds texture

Image

This is the crome2.tobj:

map 2d
/vehicle/truck/kenworth_ford/crome2.dds
addr
clamp_to_edge
clamp_to_edge
usage ui

and this is the xx.pit line:

Texture {
Tag: "texture[0]:texture_base"
Value: "/vehicle/truck/kenworth_ford/crome2"

Here's what I have in Blender:

Image

I admit being a little lost ... Did I forget something?
I used this configuration for a long time without worry and it suited me well.
When I exported I got my .pim, .pit ... files in the "base_exp" folder to convert them with conversion tools 2.10

Thank you in advance for your help ;)
Sorry for my English ... :D

berjangun
Posts: 3
Joined: 25 Aug 2015 14:24

Re: SCS Blender Tools

#2212 Post by berjangun » 21 May 2020 13:11

How can I creat PIA files for modding on the Anim? I want to change something in the Anim but nothing in the game change.

User avatar
ReddLeggs
Posts: 28
Joined: 08 Mar 2019 02:55

Re: SCS Blender Tools

#2213 Post by ReddLeggs » 21 May 2020 19:56

One way is to extract the animation files from a command line with converter_pix.exe

This video should help you:

https://www.youtube.com/watch?v=DpUSlQxMVuw&t=558s
Last edited by ReddLeggs on 22 May 2020 02:29, edited 1 time in total.
Intel® Core™i7-6700k Quad Core @ 4.60GHz | ASUS ROG MAXIMUS VIII HERO ALPHA
G.SKILL 32GB TridentZ DDR4 PC4-25600 3200 | EVGA GeForce GTX 1080 Ti SC Black Edition
SAMSUNG 850 Pro 500GB | Samsung 970 EVO 500GB - NVMe PCIe M.2 | Alienware AW3418DW

User avatar
xXCARL1992Xx
Posts: 11639
Joined: 17 Aug 2016 12:18
Contact:

Re: SCS Blender Tools

#2214 Post by xXCARL1992Xx » 21 May 2020 19:57

you dont need converter pix at all, converterPIXwrapper does everything for you, you just select the model and its animation and start working with it
Image
| !!!NO SUPPORT OR REQUESTS OF ANY SORT VIA PM!!! | Screenshot Thread | Steam Workshop | World of Trucks Profil |

Ripperino2K
Posts: 11
Joined: 25 Aug 2018 10:50

Re: SCS Blender Tools

#2215 Post by Ripperino2K » 26 May 2020 16:22

Hey all i just started trying blender recently and now i successfully added extra parts on the scania next gen from Eugene on the cabin.
Now when i export that all goes well and i am able to reimport the model again with the new attached stuff , but when i go and try to pack the mod so i can test ingame im getting bombarded with errors.
These are few of them the log is bigger then that but its the same error with only about other parts. :?:

*** ERROR *** : /vehicle/truck/upgrade/rearmudflaps/scania_2016/std_scania_logo.dds: copy operation failed.


00:00:01.512 : [linked_bt_a12be1fa1bee3c0393ab2a19608b89b6cc45be68] tobjcopy /vehicle/truck/upgrade/rearmudflaps/scania_2016/v8_scania_logo.tobj
00:00:01.514 : <ERROR> errwarn:
00:00:01.515 : <ERROR> *** WARNING *** : /vehicle/truck/upgrade/rearmudflaps/scania_2016/v8_scania_logo.tobj: Do not use 'nocompress' for .dds files - it is ignored.

*** ERROR *** : /vehicle/truck/upgrade/rearmudflaps/scania_2016/v8_scania_logo.dds: copy operation failed.


00:00:01.515 : [linked_bt_a12be1fa1bee3c0393ab2a19608b89b6cc45be68] tobjcopy /vehicle/truck/upgrade/storage/scania_2016/plain_grey.tobj
00:00:01.515 : <ERROR> errwarn:
00:00:01.515 : <ERROR> *** WARNING *** : /vehicle/truck/upgrade/storage/scania_2016/plain_grey.tobj: Do not use 'nocompress' for .dds files - it is ignored.



EDIT

Okay so i have read somewhere that i should delete all the TOBJ files so thats what i did and the pack mod was successful this time.
But there is a new problem :lol: , the whole truck is red with TEXTURE NOT FOUND , also the 2 things i added on the cabin is not present.
I used 2 pieces from a different truck and added those on the cabin https://gyazo.com/f614d0f7417a3bc478ced20b3fa81f71

EDIT 2

Been trying for over 12 hours now and im giving up.
I was using the version from few months back and tought updating would help but guess not.
Nothing works , if i reimport the truck in blender i can see the changes and see the 2 plates i added on the grill.
If i use Bens easy modding tool i can see in modelvieuwer the 2 plates , but ingame its not showing and red textures not found all over the place.

Ripperino2K
Posts: 11
Joined: 25 Aug 2018 10:50

Re: SCS Blender Tools

#2216 Post by Ripperino2K » 27 May 2020 10:21

So i just retried because i really wanted my stuff to work and i did exactly the same as the day before and the plates show up this time.
I just did the rookie way with attaching the plate on a existing accessory and all happen without problems.
Soon as import the chassis from eugene scania and add custom fueltanks/boxes im getting lots of errors about TOBJ again.
Right now cannot see why its doing this.

User avatar
KrysEmlyn
Posts: 203
Joined: 17 Mar 2017 12:32
Contact:

Re: SCS Blender Tools

#2217 Post by KrysEmlyn » 27 May 2020 13:44

To remove the errors about "no compress" in the .tobj files, you'll need to edit the relevant files in the directory where you set Conversion Tools to place it's outputs.
The .tobj files created by the conversion process when importing a model into Blender are simple text files that can be easily edited with a text editor.
Just delete the "no compress" tag in these .tobj files and you should have less errors when doing your exporting later.
The error does not prevent the .tobj files from being created during the exporting process.

I can't help with the error about the copy operation failing, but if you are using your mod with Eugene's mod, it should work anyways since you are relying on their mod for textures.
The only things you need to supply for your mod is the automat files that point to the textures and any texture files that you created which are not found in the source mod.

User avatar
*Coal_Bucket_Outlaw*
Posts: 53
Joined: 13 Aug 2017 01:34

Re: SCS Blender Tools

#2218 Post by *Coal_Bucket_Outlaw* » 28 Jun 2020 20:22

Is the latest version of scs blender tools (2.0.1) fully compatible with Blender 2.83 or do I need to downgrade? My blender on steam auto-updates unfortunately...

User avatar
kast
Posts: 1966
Joined: 11 Dec 2015 19:54

Re: SCS Blender Tools

#2219 Post by kast » 28 Jun 2020 20:27

looks good, i havent seen any issues

User avatar
Smarty
Beta tester
Posts: 2143
Joined: 30 Jun 2015 01:56
Location: Ontario, Canada
Contact:

Re: SCS Blender Tools

#2220 Post by Smarty » 03 Sep 2020 17:23

Blender 2.90 was released recently – is there intent for SCSBT to officially support it? They allegedly fixed snapping behaviour, so I'm very eager to upgrade.
Image

Post Reply

Return to “General discussion”

Who is online

Users browsing this forum: No registered users and 1 guest