Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab [PROBELM SOLVED]

User avatar
Farmers
Posts: 115
Joined: 15 Apr 2018 19:26
Location: France
Contact:

Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab [PROBELM SOLVED]

#1 Post by Farmers » 22 Mar 2020 10:43

I'm trying to manipulate 2 UV on one piece, but I can see no change from UV #0. All I can do is handle UV #1

Thanks for your help

Image
Last edited by Farmers on 07 Apr 2020 07:46, edited 1 time in total.

User avatar
tobrago
Posts: 1896
Joined: 19 Jun 2013 12:54
Location: Belgrade / SRB /
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#2 Post by tobrago » 22 Mar 2020 12:59

Try the "UV Maps" section to add more UV Map to the "+" button.

Image
Google translator
Greetings and cheers
Keep truckin'

Image Image Image

User avatar
Farmers
Posts: 115
Joined: 15 Apr 2018 19:26
Location: France
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#3 Post by Farmers » 22 Mar 2020 13:09

Already add it, but nothing change

Image

User avatar
tobrago
Posts: 1896
Joined: 19 Jun 2013 12:54
Location: Belgrade / SRB /
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#4 Post by tobrago » 22 Mar 2020 13:22

Then try a shader preset and then add UV Maps.

Image
Google translator
Greetings and cheers
Keep truckin'

Image Image Image

User avatar
Farmers
Posts: 115
Joined: 15 Apr 2018 19:26
Location: France
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#5 Post by Farmers » 23 Mar 2020 23:13

Only one shader is working "dif.spec.weight.opac" but it's not the same result on a road texture. I want to make like this texture. Alsways the same problem, i can't manage the "base texture" only the "over texture"

Image

User avatar
AmirMahdavi
Posts: 163
Joined: 16 Feb 2017 13:03
Location: Gilan, Iran

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#6 Post by AmirMahdavi » 24 Mar 2020 08:03

Because you always select UV_1
In topbar of UV/Image editor a drop-down list with all of UVs, select which you want and edit it.
Or in viewtopic.php?f=160&t=282777#p1317610 select another UV and then edit the uv in UV/Image editor.
Yes, i have bad english :D

User avatar
Farmers
Posts: 115
Joined: 15 Apr 2018 19:26
Location: France
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#7 Post by Farmers » 24 Mar 2020 10:02

I just tried it, even if I change the UV selection, it's still the same problem. Uv selection is good here, right?

Image

User avatar
AmirMahdavi
Posts: 163
Joined: 16 Feb 2017 13:03
Location: Gilan, Iran

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#8 Post by AmirMahdavi » 24 Mar 2020 12:44

Yes, but maybe you have exactly same uv and same texture

In UV editor, press A to select all vertex then change their location with G key
And look at 3d view and see it changed or not
Yes, i have bad english :D

User avatar
Farmers
Posts: 115
Joined: 15 Apr 2018 19:26
Location: France
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#9 Post by Farmers » 24 Mar 2020 15:13

I tried everything but it's not working.

I know it's the same texture, it's a prefab so it's normal it's the same texture :)

User avatar
xXCARL1992Xx
Posts: 12612
Joined: 17 Aug 2016 12:18
Contact:

Re: Problem with the shader "dif.spec.weight.dif.spec.weight" on prefab

#10 Post by xXCARL1992Xx » 24 Mar 2020 15:15

your UV isnt unwraped so it is only logical that the mesh looks like it looks, because every quad is now displaying this texture
Image
| !!!NO SUPPORT OR REQUESTS OF ANY SORT VIA PM!!! | Screenshot Thread | Steam Workshop | World of Trucks Profil |

Post Reply

Return to “General discussion”

Who is online

Users browsing this forum: No registered users and 1 guest