Failure in mirror distance

Post Reply
AlexW1389
Posts: 3
Joined: 06 May 2015 16:56

Failure in mirror distance

#1 Post by AlexW1389 » 06 May 2015 17:30

Hey guys,

unfortunately I have some issues with the mirror distance. Pre 1.17 I could see everything behind me. Since 1.17 the objects fade away midway to the horizon.

Fortunately I could find a pre 1.17 screenshot:

Pre 1.17
https://www.imageupload.co.uk/image/ZvCG
Since 1.17
https://www.imageupload.co.uk/image/ZvCI

I use the latest x64 Steam-Version 1.17.1s and the latest nVidia driver 350.12.

My current settings:
Resolution: 1920x1080
Anisotropic Filtering: 16
Anti-aliasing (MLAA): On
Color correction: On
Depth of Field: On
Grass Density: High
High Dynamic Range: On
Light Visibility Ranges: High
Mirror Distance: Ultra
Mirror Quality: High

Normal Maps: On
Pedestrians: On
Reflection Detail: High
Scaling: 300%
Secondary Vehicle Lights: On
Shadow Texture Size: High
Sunshafts: On
Texture Quality: High
Traffic Headlights: On
Vegetation Detail: High
Weather Quality: Ultra

The error occurs in both x86 and x64 version of the game.
I tried to set the graphic settings in-game (usually I use nVidia GeForce Experience).
I tried to set the mirror distance and quality to low, saved the settings and raised them to high/ultra again.
I tried to lower the scaling to 100%.
All tests above were of no avail.

Further I use no mods, except the official DLCs.

Hope you guys have a solution for this issue.

Cheers
Alex
Last edited by AlexW1389 on 06 May 2015 17:46, edited 1 time in total.

User avatar
Max
SCS Software
Posts: 5982
Joined: 26 Nov 2012 10:00
Location: SCS, Prague

Re: Failure in mirror distance

#2 Post by Max » 06 May 2015 17:46

try to set r_view_mirror_distance in config/console to higher value.
Nobody can tell you anything about it. Those who know about it aren't allowed to talk. And those who talk know nothing.

AlexW1389
Posts: 3
Joined: 06 May 2015 16:56

Re: Failure in mirror distance

#3 Post by AlexW1389 » 06 May 2015 18:34

Thanks Max, that worked.
After a test I set the graphics settings again via GeForce Experience and the value was lowered again. So seems to be an issue with the recommended settings by GF Experience.
Still strange, that the values hasn't been raised when I deactivated GF Experience and set the settings in-game :/

AlexW1389
Posts: 3
Joined: 06 May 2015 16:56

Re: Failure in mirror distance

#4 Post by AlexW1389 » 06 May 2015 18:56

After another test, there actually might be an issue with the game after all.

I entirely closed GF Experience, cut off the config file from the documents folder and started ETS2, so that the game will create a new config file (so I could check the original value for the ultra setting).
I set all graphics settings to the highest available value, applied the settings and closed the game.
Still "uset r_mirror_view_distance" is set to "200" what is far too low for an ultra mirror distance setting (in my humble opinion it may be 2048 or even 4096).

Maybe the devs might want to have a look at this.

Here is what my newly generated config looks like, with all settings set to the highest value in-game:

Code: Select all

# prism3d variable config data

uset r_full_resolution_corrections "0"
uset r_force_color_shadowmaps "0"
uset g_hw_info "1"
uset g_sns ""
uset g_line_sort "0"
uset g_cargo_sort "0"
uset g_tooltip_delay "0.4"
uset g_global_force_load_selector "0"
uset g_desktop_fadeout "60"
uset g_show_game_elements "1"
uset r_wireframe "0"
uset g_interior_camera_zero_pitch "0"
uset r_segment_buffer_size "128"
uset r_multimon_exterior_in_aux "0"
uset r_multimon_interior_in_main "1"
uset r_multimon_rotation_aux "0"
uset r_multimon_rotation_right "0"
uset r_multimon_rotation_left "0"
uset r_multimon_rotation_center "0"
uset r_multimon_vert_offset_right "0"
uset r_multimon_vert_offset_left "0"
uset r_multimon_border_fov_right "0"
uset r_multimon_border_fov_left "0"
uset r_multimon_fov_vertical "0"
uset r_multimon_fov_horizontal "50"
uset r_multimon_mode "0"
uset r_use_depth_bounds "1"
uset r_show_light_pixel_coverage "0"
uset r_deferred_debug "0"
uset r_mirror_scale_y "2"
uset r_mirror_scale_x "2"
uset r_scale_y "1"
uset r_scale_x "1"
uset r_normal_maps "1"
uset r_sunshafts "1"
uset r_color_saturation "1.0"
uset r_color_yellow_blue "0.0"
uset r_color_magenta_green "0.0"
uset r_color_cyan_red "0.0"
uset r_color_correction "1"
uset r_cloud_shadows "1"
uset r_dof_filter_size "0.5"
uset r_dof_transition "400.0"
uset r_dof_start "200.0"
uset r_dof "1"
uset r_mlaa_threshold "1.0"
uset r_mlaa "1"
uset r_hdr "1"
uset r_fake_shadows "2"
uset r_sun_shadow_texture_size "4096"
uset r_sun_shadow_quality "4"
uset r_mirror_view_distance "200"
uset r_deferred_mirrors "2"
uset r_deferred "1"
uset r_nowmi "0"
uset r_startup_progress "0"
uset r_setup_done "1"
uset r_gamma "1"
uset r_manual_stereo_buffer_scale "1.0"
uset r_manual_stereo_ui_fov_game "100"
uset r_manual_stereo_ui_fov "80"
uset r_manual_stereo_ui_dist_game "0.5"
uset r_manual_stereo_ui_dist "0.8"
uset r_manual_stereo_in_menu "1"
uset r_nv_stereo_mode "2"
uset r_minimal_unfinished_frames "0"
uset r_no_frame_tracking "0"
uset r_msaa "0"
uset r_fullscreen "1"
uset r_mode "1920x1080x32x60"
uset r_path ""
uset r_device "dx9"
uset i_virtual_cursor_speed "500.0"
uset g_trackir "1"
uset g_pedestrian "1"
uset g_light_span_factor "1"
uset g_light_distance_factor "1"
uset g_vehicle_flare_lights "1"
uset g_auto_traffic_headlights "1"
uset g_traffic "1"
uset g_kdop_preview "0"
uset g_screenshot_on_bug "0"
uset g_city_name_move "0"
uset g_developer "0"
uset g_steam_rich_presence "1"
uset g_steam_browser "1"
uset g_steam_screenshots "2"
uset g_artist_id "0"
uset g_save_format "0"
uset g_flyspeed "100.0"
uset g_news "1"
uset g_colbox "0"
uset g_radio_mode "1"
uset g_ignore_low_fps "0"
uset g_truck_light_quality "1"
uset g_truck_light_specular "1"
uset g_gfx_all_scales "0"
uset g_gfx_advanced "1"
uset g_gfx_quality "-1"
uset g_hq_3d_scale "0.0"
uset g_hq_3d_screenshot "0"
uset g_menu_aa_limit "8"
uset g_additional_water_fov "20.0f"
uset g_rain_reflect_hookups "1"
uset g_rain_reflect_actor "1"
uset g_rain_reflect_traffic "1"
uset g_rain_reflect_cache "1"
uset g_rain_reflection "3"
uset g_reflection "3"
uset g_grass_density "2"
uset g_veg_detail "2"
uset g_minicon "0"
uset g_console "0"
uset g_texture_usage_stats "0"
uset g_fps "0"
uset g_stream_exts ".ogg;.mp3"
uset r_vsync "1"
uset r_anisotropy_factor "1"
uset r_texture_detail "0"
uset t_averaging_window_length "20"
Cheers

User avatar
Michal
Site admin
Posts: 809
Joined: 25 Nov 2012 22:45

Re: Failure in mirror distance

#5 Post by Michal » 06 May 2015 19:33

Low is 80
Ultra is 200

Try to set 600.
Image

User avatar
bumbumek
Posts: 3735
Joined: 02 Jun 2014 13:14
Location: Poznań, Poland

Re: Failure in mirror distance

#6 Post by bumbumek » 08 May 2015 22:40

I had the same issue, so it could be something with the engine on 1.17 patch. I put 600, and it's OK now, so thanks Michal for the hint!

User avatar
SimulatorSam
Global moderator
Posts: 6239
Joined: 05 Mar 2014 17:52
Location: United Kingdom
Contact:

Re: Failure in mirror distance

#7 Post by SimulatorSam » 22 May 2015 09:48

Michal wrote:Try to set 600.
If I were to that, I'd have 10FPS or something :lol:

Post Reply

Return to “Bugs 1.17”

Who is online

Users browsing this forum: No registered users and 1 guest