Missing textures/geometry issue.

Allerises
Posts: 5
Joined: 19 Jun 2015 14:41

Re: Missing textures/geometry issue.

#51 Post by Allerises » 20 Jun 2015 09:55

would still like a fix for the main version of the game so I can try out mods
Last edited by Deemer on 20 Jun 2015 11:15, edited 1 time in total.
Reason: Do not quote message above yours. [2.4]

superlagger599
Posts: 2
Joined: 21 Jun 2015 11:37

Roads and buildings not loading

#52 Post by superlagger599 » 21 Jun 2015 11:46

Image

Hi all, I am having a graphical issue with the game and I was wondering if anyone knows how to fix it? The road textures and buildings are not appearing but they appear to be there as I am driving into invisible walls. I have tried lowering the graphics settings (although I might have missed something), restarting the game and uninstalling and reinstalling through Steam but it has not fixed the problem. I have an older MacBook Pro 13" (2011 or 2012 model if iirc) running on OS X Yosemite 10.10.3, 8GB 1333 MHz DDR3 RAM, Intel i5 2.4 GHz processor and Intel HD 3000 512 MB Graphics Card. Is there anyway to fix the problem or is my computer unable to run the game? Thanks in advance for your help!
Last edited by Deemer on 21 Jun 2015 12:34, edited 2 times in total.
Reason: Merged.

superlagger599
Posts: 2
Joined: 21 Jun 2015 11:37

Re: Missing textures/geometry issue.

#53 Post by superlagger599 » 21 Jun 2015 15:23

(For Mac users) After reading through the replies in this thread I have managed to fix the problem. As Allerises has said switching the game back to osx_beta version causes the textures to load properly. Right-click Euro Truck Simulator 2 in the Steam library, select Properties, go to the betas tab and under "Select the beta you would like to opt into:" select "osx_beta - Beta test of OSX version" from the drop down menu. Hope this helps!

Allerises
Posts: 5
Joined: 19 Jun 2015 14:41

Re: Missing textures/geometry issue.

#54 Post by Allerises » 25 Jun 2015 14:45

would REALLY like an update to fix this though, since mods and whatnot D:

User avatar
Sir_Tramalot
Posts: 61
Joined: 07 Apr 2014 10:15
Location: United Kingdom
Contact:

Weird Graphics problem

#55 Post by Sir_Tramalot » 30 Jun 2015 19:10

OK, so I have owned this game for coming up to 4 years now, and it has worked perfectly for me, until recently. Since the last week, the graphics have been going weird, with things like streetlamps, signs and shadows popping in and out. I bought the Scandinavia DLC on release day, so that shouldn't be it, and I have tried running a vanilla profile and re-installing the game.
Logfile: http://pastebin.com/hjBY2ATX

(Look at the streetlamp roughly centre change position)(click to enlarge)
Image
Image


Any help would be much appreciated!
EDIT: Using Windows 7 Home Premium SP1, Packard Bell Easynote TS13HR Laptop, 8GB RAM, Intel 3000 HD Graphics, Intel Core i3-2310M CPU @ 2.10GHz. Running 64 bit mode.
Heritage bus co-owner - P701 BTA

User avatar
Axel Slingerland
Posts: 9035
Joined: 22 Oct 2013 07:55
Location: The Lost Coast

Re: Weird Graphics problem

#56 Post by Axel Slingerland » 30 Jun 2015 23:46

From what I've been told, SCS knows about this and it will be fixed in the next update. If your game is like mine, it only happens on the original map and not in Scandinavia. But then again, if you look at it closely, Scandinavia looks like it's from a different game. It's like ETS3. I wish they would redo the entire map the way it is up there. But if they did, it probably would be ETS3!
You can call me Ax

Image

User avatar
Sir_Tramalot
Posts: 61
Joined: 07 Apr 2014 10:15
Location: United Kingdom
Contact:

Re: Weird Graphics problem

#57 Post by Sir_Tramalot » 01 Jul 2015 05:00

Just tried, it dosen't affect Scandinavia, so that is hopefully it. Thanks, that has given me relief that my graphics isn't dying.
Heritage bus co-owner - P701 BTA

User avatar
Sir_Tramalot
Posts: 61
Joined: 07 Apr 2014 10:15
Location: United Kingdom
Contact:

Re: Weird Graphics problem

#58 Post by Sir_Tramalot » 01 Jul 2015 20:21

Is there any idea when this update is coming, because the game is virtually unplayable for me.
Heritage bus co-owner - P701 BTA

User avatar
Unco
Posts: 2561
Joined: 02 Jan 2013 21:13
Location: Denmark

Re: Missing textures/geometry issue.

#59 Post by Unco » 01 Jul 2015 21:38

Topics merged. Please see suggested workarounds on page 1.

User avatar
Sir_Tramalot
Posts: 61
Joined: 07 Apr 2014 10:15
Location: United Kingdom
Contact:

Re: Missing textures/geometry issue.

#60 Post by Sir_Tramalot » 04 Jul 2015 17:37

Heritage bus co-owner - P701 BTA

Post Reply

Return to “Bugs 1.17”

Who is online

Users browsing this forum: No registered users and 1 guest