Disappearing AI bug [FIXED]

User avatar
room217au
Posts: 2929
Joined: 17 Jul 2015 01:55
Location: 'Straya

Re: Disappearing AI bug

#21 Post by room217au » 16 Jan 2016 05:43

I gotta say, I see it now. Or don't, as the case may be. Sitting in my truck on this overpass in Stockholm and watching the traffic take the ramp from IKA to the main highway under me, I "look away" and when looking back at the same piece of highway, the vehicle has vanished.

Not a clean profile here, but no map mods. Only one truck mod and a couple of wheel mods and trailer mods, but I do get the exactly the same game.log errors as roggek.
Two wrongs don't make a right, but three lefts.. do.

User avatar
SiSL
SCS Software
Posts: 9683
Joined: 27 Oct 2013 06:23
Contact:

Re: Disappearing AI bug

#22 Post by SiSL » 16 Jan 2016 05:50

This happens on vanilla, go to any place, turn your mouse on a junction to one side than to other, you will see "unpassed" vehicles "looks like they passed" and appearing around junctions.

As I said, this is my problem with AI mainly. When I turn my mouse to look to other side or interior, suddenly one of them "spawn" right at my other side and crashes. This is somewhat seems to be "when not looking" save-cpu option but it is going wild lately. Spawning should not be "that close" to the viewer...

User avatar
dionialex1988
Posts: 19
Joined: 06 Mar 2014 06:53

Re: Disappearing AI bug

#23 Post by dionialex1988 » 21 Jan 2016 15:38

Hello guys!

I made a video showing a bit more of the problem!

https://www.youtube.com/watch?v=kne67AV8Xn8

Note that from 3 minutes, when entering in another route, the traffic on this route starts to flow normally! But, to return to the first route, the traffic starts to disappear!

PS: I started a new profile, without any mods, but the problem persists...

oll
Posts: 17
Joined: 06 Jan 2016 21:53

Re: Disappearing AI bug

#24 Post by oll » 21 Jan 2016 19:18

Hello!

Same here!

My vidéo => https://www.youtube.com/watch?v=nXaNCeJ ... e=youtu.be

I can confirm the AI cars disappering at the roundabout at all the map!

User avatar
HarryTuttle
Posts: 8
Joined: 07 Aug 2015 17:45

Re: Disappearing AI bug

#25 Post by HarryTuttle » 22 Jan 2016 21:02

Hi there,

Imo we`re discussing about 2 different topics in this thread. It was opened by DragonzDoom to point out an obvious map bug which leaves some errors in gamelog and makes the AI disappear at a certain point. Later on we started to debate about vanishing AI depending on our visual direction.

To DragonzDoom`s prob: I confirm this and I´m somewhat surprised that none of the devs made a remark to it. The errors

Code: Select all

<ERROR> [traffic_area] Crossroad traffic area contains 'not in ui map' item 0x2934F74455A02A3! Expect problems with AI navigation.
<ERROR> [traffic_area] Crossroad traffic area contains 'not in ui map' item 0x2934F74368A02A7! Expect problems with AI navigation.
<ERROR> [traffic_area] Crossroad traffic area contains 'not in ui map' item 0x2934F74455A02A3! Expect problems with AI navigation.
<ERROR> [traffic_area] Crossroad traffic area contains 'not in ui map' item 0x2934F74368A02A7! Expect problems with AI navigation.
were completely new to me, but they plainly say that there`s a problem with a crossroad leading into an out-of-map-area. And that`s what happening at this point of the map: a line of prefabs leads to a road which is not shown in UI map. I can`t remeber this has ever been a problem in former versions but it seems to be now.
I just experimented a bit with this area and simply activated "Show in UI map"-property for those 2 short roadsegments that lead out of the map. Et voila, the number of errors was reduced to one, and most important: the AI doesn`t disappear anymore! 8-)

The other topic: in freecam view traffic has ever been spawned in dependency to your visual direction and most of the AI which you turn your back to has been deleted. That`s no problem at all and may depend on the more complex internal rules for traffic-spawning and save some performance.
But I never recognized this in cabin view though some of the vids are pretty obvious. This would be an issue. As a good driver I have a look to the left and to the right at crossroads to watch the traffic and not to delete it. ;)

User avatar
dionialex1988
Posts: 19
Joined: 06 Mar 2014 06:53

Re: Disappearing AI bug

#26 Post by dionialex1988 » 23 Jan 2016 01:39

Well, then it is proved that the game is with problems, right?

DragonzDoom
Posts: 304
Joined: 03 Mar 2014 16:58

Re: Disappearing AI bug

#27 Post by DragonzDoom » 23 Jan 2016 05:12

Correct, but I don't think a patch will come until, after American Truck Simulator is out and selling.

User avatar
dionialex1988
Posts: 19
Joined: 06 Mar 2014 06:53

Re: Disappearing AI bug

#28 Post by dionialex1988 » 23 Jan 2016 13:28

It makes sense, once there are only a few days to the release of ATS! But will be this problem is already known to the members of the SCS?
Ps: Yesterday came a small game update. I thought it might be related to this problem, that is, that would be a possible fix, but the traffic continues to disappear... :(

I hope that the ATS does not come with this problem too!! It is hard to play that way...

oll
Posts: 17
Joined: 06 Jan 2016 21:53

Re: Disappearing AI bug

#29 Post by oll » 23 Jan 2016 19:46

dionialex1988 wrote:[...]
Ps: Yesterday came a small game update. I thought it might be related to this problem, that is, that would be a possible fix, but the traffic continues to disappear... :(

[...]
Same thing for me.

The traffic continues to disappear...

oll
Posts: 17
Joined: 06 Jan 2016 21:53

Re: Disappearing AI bug

#30 Post by oll » 02 Feb 2016 22:00

No news?

Impossible to report this bug for next update?

Post Reply

Return to “Bugs 1.22”

Who is online

Users browsing this forum: No registered users and 1 guest