Annoying sound volume bugs

Post Reply
User avatar
EvgenKo423
Posts: 579
Joined: 04 Nov 2015 07:36
Location: Russia
Contact:

Annoying sound volume bugs

#1 Post by EvgenKo423 » 12 Feb 2016 16:58

Preparations:
  1. Go to your Audio settings;
  2. Set the Master volume to 0.5;
  3. Set the Sound effect volume to 0.5;
  4. Turn off the Music (to hear easily);
  5. Use a headphones, if possible (to hear easily).
Bug #1:
  1. Go to About -> Truck Browser. Sound volume is as expected;
  2. Click through the top menu. Sound volume is 2 times louder!
Bug #2:
  • Go to any tab in Truck Browser, click through items to the left. No sound at all (bug?);
  • Go to the Accessories tab;
  • Click through the accessory pins. Sound volume is 2 times louder than expected!
Bug #3:
  • Select Light Bar pin (for example);
  • Click through the items to the left. Sound volume is 2 times louder than expected!;
  • Click through the red pins on a light bar. Sound volume is 2 times louder than expected!;
  • Click through the items to the left (switch between the light bar addons). No sound at all (bug?);
  • Delete the light bar addon by pressing [X]. Sound volume is as expected;
  • Delete the light bar itself. Sound volume is ~3 times louder than expected!
Same for interior accessories.

Bug #4:
  1. Go to About -> Trailer Browser;
  2. Click through the first drop-down. Sound volume is 2 times louder!;
  3. Click through the second and third drop-downs. Sound volume is as expected.
All of the above:
Reproducibility: always.

Bug #5:
This one is the most annoying...
[Edit:]
When driving like usual, going back to the game desktop from time to time. When opening a map or music player through the keyboard shortcut while driving. When finishing a delivery, after detaching a trailer, when the stats appears. In these cases I'm getting the same loud (~2-4 times louder then it should) *TICK* sound, and it really beats my ears (I'm playing in a headphones)!
For this one, unfortunately, reproducibility: random. Unfortunately, I have no idea how to reproduce it, I've tried a lot, it just happens randomly while playing. :(
Can happen multiple times per play session, can not to happen at all. Looks like some race condition. :ugeek:

Version: 1.22.2.7s, 64-bit.
Also, IIRC, it happens to me for a long time, ever since I bought this game, i.e. it probably existed before the patch 1.17.x.

I'm really looking forward for it to be fixed (#5 mostly), but it looks almost impossible... :cry:

P.S.:
If you need, here is some of my specs:
  • Processor: Intel Core i7 860 @ 2.8GHz (4 cores, 8 threads);
  • Memory: 8GB;
  • Video card: GeForce GTS 450 [drivers: 353.62];
  • Audio card: ASUS Xonar D1 [drivers: UNi Xonar 1822 v1.75a r2 ("a" is not "alpha" here)] (yes, I have a dedicated sound card, don't ask me why...);
  • OS: Windows 7 x64 SP1.
However, I used many driver versions for both of them through time, but #5 was always there.

P.P.S.:
I had to edit a post, I had no way to save moderator's comment as it's not a part of the post. Sorry.
Last edited by EvgenKo423 on 19 Mar 2016 11:22, edited 2 times in total.

User avatar
EvgenKo423
Posts: 579
Joined: 04 Nov 2015 07:36
Location: Russia
Contact:

Re: Annoying sound volume bugs

#2 Post by EvgenKo423 » 19 Mar 2016 10:55

Version: 1.23.0.2s.

Still nothing of these fixed. Any news about it?

Drive Safely
Posts: 2741
Joined: 20 Jun 2015 06:17
Contact:

Re: Annoying sound volume bugs

#3 Post by Drive Safely » 19 Mar 2016 11:09

What do you mean by tick sound? You mean the click sound for the user interface?

User avatar
EvgenKo423
Posts: 579
Joined: 04 Nov 2015 07:36
Location: Russia
Contact:

Re: Annoying sound volume bugs

#4 Post by EvgenKo423 » 19 Mar 2016 11:15

Yes, the UI click sound.

Drive Safely
Posts: 2741
Joined: 20 Jun 2015 06:17
Contact:

Re: Annoying sound volume bugs

#5 Post by Drive Safely » 20 Mar 2016 06:53

Haven't encountered that bug myself but you can mod the sounds to a lower or muted volume.

User avatar
Reinhard
Posts: 5210
Joined: 20 Dec 2012 16:46
Location: Nimby, District of Berlin

Re: Annoying sound volume bugs

#6 Post by Reinhard » 20 Mar 2016 08:00

Funny. Never noticed that, because I replaced that sound with a more gentle one even before I really started to play this game. I used a leftover of an own ETS 1 mod.

In ETS 1, there was an even more alarming, very loud "GONG!" sound, for every click. Drove me nuts, because I always use headphones. It was like a whack on my head. Many whacks. In fact, that was the reason why I asked google how to fix it, and how I encountered ETS 1 forums and modding. In early 2009.

The first game-mod I ever used was one I did myself. :D

If this sound wasn't in ETS 1, I may have missed modding, modest 3D-editing, and mapping. :D

User avatar
EvgenKo423
Posts: 579
Joined: 04 Nov 2015 07:36
Location: Russia
Contact:

Re: Annoying sound volume bugs

#7 Post by EvgenKo423 » 20 Mar 2016 10:09

Drive Safely, I was sure you propose to mode it. :) But no, it's impossible, because the same single sound is played with different volume in different situations. Or at least it shouldn't be like that even if it's possible. Volume level should be uniform, especially for similar things.

Reinhard, also playing with headphones, that's why I lowered the volumes, they were to loud.
Nice story! Good to see you here, one more good modder is never excess. ;)

User avatar
Max
SCS Software
Posts: 6120
Joined: 26 Nov 2012 10:00
Location: SCS, Prague

Re: Annoying sound volume bugs

#8 Post by Max » 20 Mar 2016 10:32

i suspect its ui issue.
i mean if there is one sound played with different volume, its more probably there are multiple instances of that one sound - eg one for opening screen (click of element that caused it) a one for, say, every list there as it changes its value on init. could that be the case?

i can checkt it but it wont be fixed soon definitely as it is lot of work with only minor gain.
Nobody can tell you anything about it. Those who know about it aren't allowed to talk. And those who talk know nothing.

IonutL
Posts: 3177
Joined: 13 Apr 2014 20:16

Re: Annoying sound volume bugs

#9 Post by IonutL » 20 Mar 2016 13:44

EvgenKo423 wrote:Yes, the UI click sound.
I've also encountered that loud click sound, I guess in the same circumstances you described.
Also had someone encountered sound relics, when changing cameras, from the outside ones to the interior one? i.e. you hear both int and ext sounds at the same time, or it might be something related to sound drivers.

User avatar
EvgenKo423
Posts: 579
Joined: 04 Nov 2015 07:36
Location: Russia
Contact:

Re: Annoying sound volume bugs

#10 Post by EvgenKo423 » 20 Mar 2016 16:20

Max wrote:could that be the case?
Are you asking me? :lol: It's you the developer, not me. You probably know better how the sounds are used...

Max, Drive Safely, I've re-checked the sounds. There are two "click" sounds in a game: /sound/ui/click.ogg and /sound/ui/click_soft.ogg. I am talking about the last and most used one. Now I am 100% sure, it's the same sound with a different volume.
Sounds for "opening screen" and "list switching" (e.g. on a Freight Market screen) are of the same kind and volume.

[Edit:] I think I got what you mean now... You mean I hear the same sound twice, so they're adding? I don't think so. I don't hear any slightest delay there. But again, you should see it better.
Consider bug #2, step 1: there is no sound when you click through items, so there is nothing to add over. However, in bug #1, step 2 the volume is 2 times louder. So, it's not like you're clicking on two buttons at the same time.

Sorry, IonutL, haven't encountered that.

Post Reply

Return to “Bugs 1.22”

Who is online

Users browsing this forum: No registered users and 1 guest