I'm sorry this has to be said, the terrible state of AI traffic

User avatar
Bedavd
Posts: 657
Joined: 31 May 2018 15:09
Location: Michigan -> Washington

Re: I'm sorry this has to be said, the terrible state of AI traffic

#61 Post by Bedavd » 20 Nov 2020 14:42

Has anyone else been experiencing this? I only run with 3 mods, none of which I think would cause this but I'm not officially submitting a bug report because of that.

All over Colorado (haven't checked outside of the state because I haven't left yet) I've been seeing AI cars stop at the beginning of a left turn only lane and just sitting there with their signal on.

This particular instance is in Grand Junction but I know for sure I've seen it in Steamboat Springs and a few other locations. No collisions with the other AI, the turn lane is completely clear, light cycle doesn't matter.
Image
Image
Check out my Michigan research map!

Check out my ATS IRL map!
*Colorado added! LA, and San Diego are unmapped out of protest for their future rework*

jarryed
Posts: 879
Joined: 15 Mar 2018 12:08

Re: I'm sorry this has to be said, the terrible state of AI traffic

#62 Post by jarryed » 20 Nov 2020 14:43

Yep. This happens all over Colorado for me.


User avatar
Bedavd
Posts: 657
Joined: 31 May 2018 15:09
Location: Michigan -> Washington

Re: I'm sorry this has to be said, the terrible state of AI traffic

#64 Post by Bedavd » 20 Nov 2020 15:01

Jazzycat's AI traffic, Police car pack, and my livery. Since they're AI mods I can see how they might cause this, but don't think they are. Plus the cars that have been doing it are both modded and SCS originals. That's why I'm curious to see if others have seen it.
Check out my Michigan research map!

Check out my ATS IRL map!
*Colorado added! LA, and San Diego are unmapped out of protest for their future rework*

User avatar
abasstreppas
Posts: 8156
Joined: 06 Feb 2013 20:32
Location: On an island outside another island, outside another island...
Contact:

Re: I'm sorry this has to be said, the terrible state of AI traffic

#65 Post by abasstreppas » 20 Nov 2020 15:31

.
Last edited by abasstreppas on 20 Nov 2020 18:37, edited 1 time in total.
Image


User avatar
abasstreppas
Posts: 8156
Joined: 06 Feb 2013 20:32
Location: On an island outside another island, outside another island...
Contact:

Re: I'm sorry this has to be said, the terrible state of AI traffic

#67 Post by abasstreppas » 20 Nov 2020 18:47

I misunderstood that problem with left turn Ai's. I've seen a similar problem frequently in Colorado (have just been in Co lately).

This is what's happen quite often. An Ai is just stuck in the left turn lane, sitting there without moving. It also happen at traffic light crossings and could be quite annoying if you end up behind those :roll:

Adding coordinates for the pic. It's a modded profile so I can't make a proper bug report

Code: Select all

[20/11/2020 19:11:36] (sec-0013+0000);-51856.5;92.42;52.7067;0.719753;-0.128784
Attachments
ats_20201120_191058_00.jpg
Image

User avatar
-Raiden-
Posts: 659
Joined: 27 Jan 2013 14:28
Location: Münster, Germany
Contact:

Re: I'm sorry this has to be said, the terrible state of AI traffic

#68 Post by -Raiden- » 21 Nov 2020 11:29

Since the release of ETS2, the AI has really improved over the years, but I have to admit there are certain things / behavioural patterns of the AI vehicles which can drive me batsh*t crazy :o

First of all - the frequently appearing slowdowns and brakechecks:
I've been playing ATS so much lately that I already can anticipate when those things appear...
If I know there's an on- or off-ramp incoming, I already switch to the left lane (if there is one), so I don't get caught up and hammer into one of the AI vehicles which spontaneously decide that an almost-full-stop is needed. Even if there is no other traffic at all. :|

Another thing which often bugs me is that AI vehicles are "crawling" around a lot slower than the actual speed limit for that stretch of road. :?
I've encountered them doing 35-45 in a 65+ zone on a straight road without any big elevation changes. Since I try to stick to the road rules as close as possible this results in another brake check and getting stuck behind them. And it can be pretty nerve-wrecking if you are in a hurry, because you have a small time frame to pick up or deliver a load.

Personally I have the feeling that AI used to be a bit better a few patches ago, but on the other hand I'm, honestly, not able to really pinpoint when which things started worsening.

I think a lot of this might have to do with the AI's "environmental detection" and its more "conservative behaviour" to its surroundings. And yes, I remember that we also had AI-programmings in the past which resulted in just the opposite of what I described above. At some point in time we really had AI traffic that liked to "go rowdy", so...
SCS-trucksim veteran - ETS2: since December 2012 / ATS: since release in February 2016 / Several 18WoS parts even before that

My Photo Album (ETS2) | My American Journeys (ATS) | My WoT-profile

User avatar
canuckster
Posts: 289
Joined: 04 Jun 2015 03:21
Location: Gothenburg SWE via Vancouver CAN

Re: I'm sorry this has to be said, the terrible state of AI traffic

#69 Post by canuckster » 21 Nov 2020 15:15

Bedavd wrote:
20 Nov 2020 14:42
Has anyone else been experiencing this? I only run with 3 mods, none of which I think would cause this but I'm not officially submitting a bug report because of that.

All over Colorado (haven't checked outside of the state because I haven't left yet) I've been seeing AI cars stop at the beginning of a left turn only lane and just sitting there with their signal on.

This particular instance is in Grand Junction but I know for sure I've seen it in Steamboat Springs and a few other locations. No collisions with the other AI, the turn lane is completely clear, light cycle doesn't matter.
Yeah I've experienced this, saw it for the first time today, clean installation.
A Lannister always pays his debts.
Pining to drive the Trans-Canada Highway... some eventual beautiful day.

hallux
Posts: 18
Joined: 09 Nov 2019 03:39

Re: I'm sorry this has to be said, the terrible state of AI traffic

#70 Post by hallux » 22 Nov 2020 15:51

Robinicus wrote:
19 Nov 2020 15:21

the AI slowing down when the 2 lane is expanding to a 4 lane
the constant AI plugging of scale off ramps
.
I see both of these. The other ones that bother me happen at the road construction sites that close one of two lanes on a 2-lane road, the ones with the temporary traffic lights. You could be following a truck approaching those sites, they have a green light but they STOP before proceeding through the construction zone.

Ai blocking the scale lanes has happened to me more than I want to count, those shouldn't even be an available lane for them. I might have mentioned it earlier in the thread but I also see the randomly-stopped traffic WAY before an intersection, I haven't only seen it in the left lane, I saw it in the right lane once also.

Post Reply

Return to “General discussion about the game”

Who is online

Users browsing this forum: LudoModding, ShatnersBassoon and 8 guests