ATS 1.40 discussion

User avatar
TheTiger
Posts: 1710
Joined: 13 Nov 2018 11:56

Re: ATS 1.40 Open Beta discussion

#1101 Post by TheTiger » 25 Feb 2021 17:13

Stop the train! I want to go down.
ImageImage

thesimp
Posts: 328
Joined: 28 Apr 2017 19:45
Location: The Netherlands

Re: ATS 1.40 Open Beta discussion

#1102 Post by thesimp » 25 Feb 2021 17:49

Some people have already mentioned it: where is the rain? Ever since I got into the beta I have not had any rain. I've played with the rain probability slider but only got some dark looking clouds in the skybox but no rain. Is the rain slider also in text form in the cfg file ?

User avatar
harishw8r
Posts: 1487
Joined: 14 Mar 2020 05:52
Contact:

Re: ATS 1.40 Open Beta discussion

#1103 Post by harishw8r » 25 Feb 2021 17:53

It’s strange that you haven’t seen rain. The rain probability is working as usual for me, and it’s quite challenging to drive in the rain. We definitely need some working foglights.
:idea: Paint everything black!
Screenshots thread: ETS2 | ATS
Personal blog

User avatar
koolizz
Posts: 503
Joined: 05 Aug 2019 10:30

Re: ATS 1.40 Open Beta discussion

#1104 Post by koolizz » 25 Feb 2021 17:56

Zsuzsanna wrote:
24 Feb 2021 08:33
My FPS drop when I use blinkers either when signaling turning or the four-ways when maneuvering. The cadence of the flash and the concomitant click in the cab slows and the game slows so that it only jumps/stutters forward on each flash/click. It also means I have to be slowing much earlier for turnings otherwise I am not slowed enough for the exit. Happens happens with or without mods in all truck makes but more noticeably in the Freightliner and the Western Star trucks.
This has been a problem since 1.37 when they introduced FMOD that they seem to ignore. Every now and again when blinking the game starts lagging in tempo with the blinker or hazard lights. It is happening specifically when a sound is repated rhythmically, so it has likely to do with that the sound played is hindering the game somehow. Its really weird but might have to do with the fact that this is running single cored. Its also evident its related to the sound, because if you switch to outside view when this is happening the lagging stops, because the blinker sound is not being played anymore.

User avatar
xXCARL1992Xx
Posts: 13332
Joined: 17 Aug 2016 12:18
Contact:

Re: ATS 1.40 Open Beta discussion

#1105 Post by xXCARL1992Xx » 25 Feb 2021 17:59

FMod runs on a different core then the game, those 2 are separate and the interior was always more prone to lag then the exterior
Image
| !!!NO SUPPORT OR REQUESTS OF ANY SORT VIA PM!!! | Screenshot Thread | Steam Workshop | World of Trucks Profil |

User avatar
koolizz
Posts: 503
Joined: 05 Aug 2019 10:30

Re: ATS 1.40 Open Beta discussion

#1106 Post by koolizz » 25 Feb 2021 18:03

Okay then, so explain why then it is lagging in sync rhythmically with the blinker sound sometimes when blinking, and it immediately stops if you switch to outside view or if you stay in the cabin but turn off the blinker? Something with the sound is blocking the game thread. This is not merely a interior lag issue, it seems to be specifically tied to a short sound being played repeatedly. It gets worse too when it rains too for some reason.

User avatar
DracoTorre
Posts: 10
Joined: 21 Oct 2020 15:43
Contact:

Re: ATS 1.40 Open Beta discussion

#1107 Post by DracoTorre » 25 Feb 2021 18:13

thesimp wrote:
25 Feb 2021 17:49
I've played with the rain probability slider but only got some dark looking clouds in the skybox but no rain. Is the rain slider also in text form in the cfg file ?
In the profile’s config.cfg as g_bad_weather_factor. Mine is set to 0.15, and I have seen rain several times in Oregon and Washington.
Last edited by DracoTorre on 25 Feb 2021 18:31, edited 1 time in total.

User avatar
orizon
Posts: 282
Joined: 11 May 2019 15:16
Location: Timisoara, Romania
Contact:

Re: ATS 1.40 Open Beta discussion

#1108 Post by orizon » 25 Feb 2021 18:28

Same for me. Usually, I encounter rain very often in the NW states, or in the Colorado mountains. Rest, are quite arid zones, so I didn't expect too much rain, only clouds.
Image

User avatar
Vojta
SCS Software
Posts: 426
Joined: 22 Feb 2018 16:03

Re: ATS 1.40 Open Beta discussion

#1109 Post by Vojta » 25 Feb 2021 19:08

Hi everyone,

A new ATS build 1.40.0.84 is available in public_beta on Steam.

Code: Select all

* 0149422 - Utah - I-15 - Flickering buidling
* 0146044 - wa_stripmall2.pmd - Decrease luminosity
* 0143979 - gas_shop_chemron_03.pmd - Problem with light effect on ground + decrease luminosity
* 0133601 - Colorado - US 40 - Objects
* 0147974 - hearts_ways_sign.pmd - Decrease luminosity
* 0148032 - nm_gas_station_totem_chemron.pmd - Too dark

User avatar
TruckerKid
Posts: 706
Joined: 13 Jul 2013 01:13
Location: Oklahoma, USA
Contact:

Re: ATS 1.40 Open Beta discussion

#1110 Post by TruckerKid » 25 Feb 2021 19:29

The lagging with the blinker is in fact due to both the illumination effect of the blinker (lights that actually illuminate surfaces are very demanding in this game for some reason) and the additional scenes being rendered in the mirrors. Its not the sound, you can prove this by rotating your camera slightly toward the center of the cabin when both mirrors are out of view and you will get your frames back. When you are in the interior view, you are rendering at least three scenes at the same time, the cabin view, the main mirror, and the spot mirror. When using the exterior view, only the one scene is being rendered.

Post Reply

Return to “General discussion about the game”

Who is online

Users browsing this forum: rbsanford, Tails and 12 guests