Map Editor: Background Image not loading | SOLVED - 1.38 - 1.39 Working

Post Reply
Claw57
Posts: 2
Joined: 19 Sep 2020 18:43
Contact:

Map Editor: Background Image not loading | SOLVED - 1.38 - 1.39 Working

#1 Post by Claw57 » 20 Sep 2020 02:12

Scroll down to see how to solve

Hi all!
I've been playing around with the map Editor alot recently and I decided I want to start my first project.

I've been struggling to get my Background map to load. I've been at it for hours, trying all types of ways to export my DDS image, even downloading older software to export the image exactly as shown on all of the post and videos I can seem to find.

I've finally gotten to the point where the background is pink instead of the default "no texture" red. Now I just need to figure out how to get the game to read the image.

Things I've Tried
[*]Extensive Research
[*]Adding "-force_mods" to the shortcut
[*]Different software for exporting DDS Image
[*]Opening each file in notepad to make sure they all line up to the correct directory
[*]Making sure my "editor_data.sii" is correct (It might not be still, Ill upload it)
[*]Exporting as DXT5 and 3

I'm at a real struggle hear and would love if someone could tell me what I'm doing wrong.
Is the image directory broken when I make mod a Zip file?

If you need the mod/map files let me know.
Thank you!

Editor ScreenShot

Image

=======================================================================
Materials Structure

Image

=======================================================================
Mod Folder Structure

Image

=======================================================================
Material File

Image

=======================================================================
tobj File

Image

=================================How to Solve======================================

After many hours of trying different things, I've finally found out what I've been doing wrong!

It turns out the tobj file was wrong, its not supposed to be c/User/docs...etc, its supposed to be just/material/editor/yourimage.dds

Now, if you just edit your previous tobj file like I did to say that, it wont work. So you need to generate a new one.

Open the .tobjEdit tool, drag your Image.dds into the file window. Then, delete everything before the "/material/editor/yourimage.dds"

It should look like this:
Image

Then Save As, and save it to wherever.
Then open your Map.Zip that you made in your mod folder, goto /material/editor/ , delete the old Tobj file and replace it with the new one.

Great! It should work now right? Maybe. It depends on how you exported your DDS image.
If the console says something like "incompatible image error" then youre not doomed because that happened to me!

Simply open Gimp 2, Drag your original PNG into the workspace and export as a DDS image. All of these articles I've seen tells you to export it as DXT5 or something like that. Dont change any of the DDS export settings, leave it as default.
It should look like this:
Image

Now export that sucker, go back to your zip, delete the old DDS image and replace it with the new! Launch your map editor and your background should appear.

I know this fix is only specific to few people who maybe did the tobj file wrong or exported the wrong DDS, or both like me. I hope it helps some of you out there.
This forum might not be as organized as others aswell, so I will try to make some tutorial videos on the Map Editor once I get more comfortable with it.
Attachments
editor_data.sii
(1.8 KiB) Downloaded 3 times
Core i7-8750H
24GB RAM
GTX 1060 6GB
SSD Drives

Post Reply

Return to “Help center - player to player”

Who is online

Users browsing this forum: No registered users and 1 guest