ATS Crashing on Startup.

Post Reply
LDTheCourier
Posts: 5
Joined: 13 Dec 2019 16:46

ATS Crashing on Startup.

#1 Post by LDTheCourier » 13 Dec 2019 16:50

Hello there.



I haven’t played ATS in maybe a year now. Came back to it and got some of its DLC.

I attempted to startup the game, and just as the SCS logo appears, it freezes.

This is on Steam, so I verified game files, uninstalled & reinstalled. Added this .dll file to the game folder.
Also ran in safe mode and the two other options.

Updated drivers. Had an issue with my drivers. Uninstalled and reinstalled. GeForce experience still doesn’t work. But that’s probably not an issue.

Contacted SCS support. They recommended to turn off Razer Chroma. Turned off. Still does not work.

If anyone can assist, it will be greatly appreciated. I have windows 7. 64 bit

User avatar
Madkine
Global moderator
Posts: 3488
Joined: 08 Oct 2018 16:35
Location: Australia
Contact:

Re: ATS Crashing on Startup.

#2 Post by Madkine » 13 Dec 2019 19:21

Have you installed the DX11.1 one update?
This is needed for Windows 7.

Post your game.log.txt to pastebin.com (no account needed) and then post the link here and we'll have a look for you.
The file can be found at "C:\Users\*USERNAME*\Documents\American Truck Simulator" for a default install.

LDTheCourier
Posts: 5
Joined: 13 Dec 2019 16:46

Re: ATS Crashing on Startup.

#3 Post by LDTheCourier » 13 Dec 2019 23:37

@Madkine Hello! I don't believe I have. I will take a look.

https://pastebin.com/WSNfHQS5

Apologies for the late reply.

Double Post Merged

I have looked for the 11.1 update. It appears it's only for windows 8. Only parts of it are available for windows 7. I can't seem to find that.

I somehow downloaded Dx 11 Technology update which holds a file and a 30 min audio clip of a presentation of this technology update...
I'm quite lost.
Last edited by supersobes on 14 Dec 2019 00:07, edited 1 time in total.
Reason: Replaced empty quote with mention [Forum rule 2.4.1] Double post merged [Forum rule 2.6]

User avatar
Madkine
Global moderator
Posts: 3488
Joined: 08 Oct 2018 16:35
Location: Australia
Contact:

Re: ATS Crashing on Startup.

#4 Post by Madkine » 14 Dec 2019 06:03

Unfortunately that's a silent crash.
Post your crashlog as well and hopefully a developer will have a look.

LDTheCourier
Posts: 5
Joined: 13 Dec 2019 16:46

Re: ATS Crashing on Startup.

#5 Post by LDTheCourier » 14 Dec 2019 06:11

Oh dear.

Here's the crash log.

https://pastebin.com/rA60HEij

User avatar
Max
SCS Software
Posts: 6119
Joined: 26 Nov 2012 10:00
Location: SCS, Prague

Re: ATS Crashing on Startup.

#6 Post by Max » 14 Dec 2019 14:53

Code: Select all

Fault address: 000007FEEAB23F9F 0001:00002F9F C:\Windows\system32\RzChromaSDK64.dll
this is file and address the game crashed on.
it is not our file so we can't do much. either get correctly working plugin (update chroma sdk) or stop using it.
Nobody can tell you anything about it. Those who know about it aren't allowed to talk. And those who talk know nothing.

LDTheCourier
Posts: 5
Joined: 13 Dec 2019 16:46

Re: ATS Crashing on Startup.

#7 Post by LDTheCourier » 14 Dec 2019 22:46

Hmm. I did disable Chroma and update the Razer Synapse.

What if I were to delete that file?
Last edited by Mohegan13 on 15 Dec 2019 09:43, edited 1 time in total.
Reason: Quote Removed - Don't quote the post directly above.

LDTheCourier
Posts: 5
Joined: 13 Dec 2019 16:46

Re: ATS Crashing on Startup.

#8 Post by LDTheCourier » 18 Dec 2019 14:16

Hi there. I uninstalled Chroma, now it work's fine. Thanks for your help, all!

Babyface
Posts: 6
Joined: 26 Nov 2020 08:04

Re: ATS Crashing on Startup.

#9 Post by Babyface » 26 Nov 2020 08:08

This exact same issue happened to me today , fresh install, crashes at scs logo , drivers up to date , 2080 super i7 10700k 16gb new out the box a month ago , runs everything just fine , i even downloaded directx and microsoft visual c++ (redistributable x64) nothing im on the latest windows 10. This really is killing me

https://pastebin.com/MdRaDbgC

Is it my asus aura ? Man im no wizard if i have to delete that my lights are done

Babyface
Posts: 6
Joined: 26 Nov 2020 08:04

Re: ATS Crashing on Startup.

#10 Post by Babyface » 26 Nov 2020 10:36

I fixed it i found my log i had to search the whole pc to find it. I read the log i trie dto understand it and only error was the asus thing. So i dug deeper went into the armoury crate and found something that needed an update so i did it and it fixed. But its crazy how that one thing can ruin the game like that. For someone who cannot figure this out or figure out where to get help they are helpless.

Post Reply

Return to “Technical Problems”

Who is online

Users browsing this forum: No registered users and 2 guests