[REL]City Traffic v1.0.2 for ATS v1.6

Forum rules
SCS as a company do not wish to have paid mods on this forum. While we understand that not all paid mods use the Intellectual Property of other companies/people, it is very hard to moderate what is and isn't acceptable when money is involved. There are also concerns that it could look unfavorable to potential work partners going forward if SCS allow mods that may potentially use unlicensed branding.
Posting in the Mods forum (ATS and ETS2) is restricted to sharing free-to-the-public mods and providing support for mods. For more details, please check chapters [4] and [5] of Forum Rules.
User avatar
SlavikSD
Posts: 2757
Joined: 03 Aug 2015 22:59
Location: Russia

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#11 Post by SlavikSD » 14 Apr 2017 18:45

@hoseclamp72, I get great pleasure from using your mod. Big big thanks!

User avatar
Blackspots
Posts: 7695
Joined: 13 Apr 2016 21:57
Location: Wichita Falls, TX
Contact:

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#12 Post by Blackspots » 18 Apr 2017 17:35

Ran this updated mod last night. Now the Ambulance in CA has red "no texture" constantly even when right next to it.

Plus "no suitable vehicle found for <state>" or something similar and lots of mat errors.
Author: C2C Eastern New Mexico, Texas, Oklahoma and Kansas improvments
ETS2 Map Combo: PM, Scandinavian Addon, RusMap, SR, The Great Steppe, PJ Indo Map
ATS Map Combo: Coast to Coast, CanaDream, Tonopah Reworked, US Expansion, Viva Mexico

User avatar
hoseclamp72
Posts: 146
Joined: 10 Mar 2016 07:12
Location: Ontario, Canada

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#13 Post by hoseclamp72 » 18 Apr 2017 18:43

@ ShirBlackspots, I'm not seeing any "no suitable vehicle" errors on my end so not sure what is going on with that at this point.

I do have one idea regarding the mat file errors though. SCS changed all the mat files in ATS 1.6/ETS2 1.27 so many old mods now create mat file errors unless updated. I have created a compatibility mod for this issue and forgot I had it installed.
Last edited by hoseclamp72 on 19 Apr 2017 15:01, edited 1 time in total.

User avatar
Blackspots
Posts: 7695
Joined: 13 Apr 2016 21:57
Location: Wichita Falls, TX
Contact:

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#14 Post by Blackspots » 18 Apr 2017 20:19

Can I merge the automat files with the City Vehicles mod?

Also, this was the sort of errors I was getting:

Code: Select all

01:06:58.618 : <ERROR> [parked_car] No suitable allowed vehicle for country 'California'
01:06:58.618 : <ERROR> [parked_car] No suitable vehicle model found (-110070.0;78.9;-31209.6)!
01:06:58.868 : <ERROR> [parked_car] No suitable allowed vehicle for country 'California'
01:06:58.871 : <ERROR> [parked_car] No suitable vehicle model found (-110046.2;80.5;-31233.5)!
01:07:02.254 : <ERROR> [fs] Failed to open file "/automat/b5/9072cd0880620f0755495cdc251a3107265b32.mat" in the read_only mode
01:07:02.254 : <ERROR> [resource_task] Can not open '/automat/b5/9072cd0880620f0755495cdc251a3107265b32.mat'
01:07:02.266 : <ERROR> [fs] Failed to open file "/automat/94/5bf4e07d5de96a51fa5755bdc092c29407c6f3.mat" in the read_only mode
01:07:02.266 : <ERROR> [resource_task] Can not open '/automat/94/5bf4e07d5de96a51fa5755bdc092c29407c6f3.mat'
01:07:02.267 : <ERROR> [fs] Failed to open file "/automat/0c/91db4bffa0c4457f2a9558e9fa9b9b19cfdce6.mat" in the read_only mode
01:07:02.267 : <ERROR> [fs] Failed to open file "/automat/3b/c9a25b08a3453874c50294a2f3546ea55ad3ea.mat" in the read_only mode
01:07:02.267 : <ERROR> [resource_task] Can not open '/automat/0c/91db4bffa0c4457f2a9558e9fa9b9b19cfdce6.mat'
01:07:02.267 : <ERROR> [resource_task] Can not open '/automat/3b/c9a25b08a3453874c50294a2f3546ea55ad3ea.mat'
01:07:02.267 : <ERROR> [fs] Failed to open file "/automat/2b/2b963c0601a8bf8f656b756cd8d0340952498a.mat" in the read_only mode
01:07:02.267 : <ERROR> [resource_task] Can not open '/automat/2b/2b963c0601a8bf8f656b756cd8d0340952498a.mat'
01:07:09.947 : <ERROR> [parked_car] No suitable allowed vehicle for country 'California'
01:07:09.947 : <ERROR> [parked_car] No suitable vehicle model found (-110046.2;80.5;-31233.5)!
--EDIT--
No more mat errors, but I still do get this

Code: Select all

00:20:19.073 : <ERROR> [parked_car] No suitable allowed vehicle for country 'California'
00:20:19.073 : <ERROR> [parked_car] No suitable vehicle model found (-93603.8;5.8;24688.4)!
Other traffic mods I have installed are Jazzycat's AI traffic pack v2.2, ATSHighway Patrol and Real Trash Truck and Taxi.

Also, here's the Ambulance now with that compatibility package:
https://www.dropbox.com/s/a4r46lsyq77ig ... 1.jpg?dl=0
It was what had the red no texture the entire time you saw it.
Author: C2C Eastern New Mexico, Texas, Oklahoma and Kansas improvments
ETS2 Map Combo: PM, Scandinavian Addon, RusMap, SR, The Great Steppe, PJ Indo Map
ATS Map Combo: Coast to Coast, CanaDream, Tonopah Reworked, US Expansion, Viva Mexico

User avatar
hoseclamp72
Posts: 146
Joined: 10 Mar 2016 07:12
Location: Ontario, Canada

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#15 Post by hoseclamp72 » 18 Apr 2017 22:17

Thanks. Glad the automat issue is fixed. Regarding the parked car errors, that is likely related to the Highway Patrol mod. I have fixed my own copy of that mod to remove those errors.

User avatar
Blackspots
Posts: 7695
Joined: 13 Apr 2016 21:57
Location: Wichita Falls, TX
Contact:

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#16 Post by Blackspots » 18 Apr 2017 23:02

Could you tell me how to fix that?

--EDIT--
I found your post on what you did to fix it in the relevant thread (ATS Highway Patrol).

Thank you for sharing the edit to the unit hookup parked_cars.sii. It eliminated all but one of the

Code: Select all

"00:17:44.536 : <ERROR> [parked_car] No suitable vehicle model found (-98778.4;11.5;23599.7)!"
when I was flycamming down I-5 then I-8
Author: C2C Eastern New Mexico, Texas, Oklahoma and Kansas improvments
ETS2 Map Combo: PM, Scandinavian Addon, RusMap, SR, The Great Steppe, PJ Indo Map
ATS Map Combo: Coast to Coast, CanaDream, Tonopah Reworked, US Expansion, Viva Mexico

User avatar
hoseclamp72
Posts: 146
Joined: 10 Mar 2016 07:12
Location: Ontario, Canada

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#17 Post by hoseclamp72 » 19 Apr 2017 00:29

That last one is likely due to the parked police car with driver near San Diego. The relevant lines for the driver instance need updated as well. Not at my computer right now (at work lol) so can't give the exact details.

User avatar
Blackspots
Posts: 7695
Joined: 13 Apr 2016 21:57
Location: Wichita Falls, TX
Contact:

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#18 Post by Blackspots » 19 Apr 2017 00:51

Since its right below the line you edited, basically

Code: Select all

parked_car: police.always.parked.physics.driver
{
	low_poly_only: false
	always_visible: true
	driver: true

	allowed_vehicle[]: "traffic.ford_tarus_p"
}
becomes

Code: Select all

parked_car: police.always.parked.physics.driver
{
	low_poly_only: false
	always_visible: true
	driver: true

	allowed_vehicle[]: "traffic.police"
	allowed_vehicle[]: "traffic.ford_tarus_p"
	allowed_vehicle[]: "traffic.police_ca"
	allowed_vehicle[]: "traffic.police_nv"
	allowed_vehicle[]: "traffic.police_az"
	allowed_vehicle[]: "traffic.ford_exp_ca"
	allowed_vehicle[]: "traffic.ford_exp_nv"
	allowed_vehicle[]: "traffic.ford_exp_az"
	allowed_vehicle[]: "traffic.ford_tau_ca"
	allowed_vehicle[]: "traffic.ford_tau_nv"
	allowed_vehicle[]: "traffic.ford_tau_az"
	allowed_vehicle[]: "traffic.charger6_ca"
	allowed_vehicle[]: "traffic.charger6_nv"
	allowed_vehicle[]: "traffic.charger7_ca"
	allowed_vehicle[]: "traffic.charger7_nv"
	allowed_vehicle[]: "traffic.charger8_ca"
	allowed_vehicle[]: "traffic.charger8_nv"
	allowed_vehicle[]: "traffic.newf_exp_ca"
	allowed_vehicle[]: "traffic.newf_exp_az"

}
Correct?
Author: C2C Eastern New Mexico, Texas, Oklahoma and Kansas improvments
ETS2 Map Combo: PM, Scandinavian Addon, RusMap, SR, The Great Steppe, PJ Indo Map
ATS Map Combo: Coast to Coast, CanaDream, Tonopah Reworked, US Expansion, Viva Mexico

User avatar
hoseclamp72
Posts: 146
Joined: 10 Mar 2016 07:12
Location: Ontario, Canada

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#19 Post by hoseclamp72 » 19 Apr 2017 02:48

Yeah that looks correct from what I remember.

User avatar
yaumeister
Posts: 534
Joined: 05 Apr 2014 21:18
Contact:

Re: [REL]City Traffic v1.0.2 for ATS v1.6

#20 Post by yaumeister » 21 Apr 2017 11:01

I can also confirm the CA ambulance now works with the extra automat package supplied by hoseclamp72.

May I suggest making the CA ambulance available in other states since you have removed the CA marking in future versions? Always seem a little odd to me that SCS decided to make ambulance for CA only, surely people living outside CA deserves emergency healthcare too :lol:

P.S - Still hoping to see US50/CA99!
Image

Post Reply

Return to “Traffic”

Who is online

Users browsing this forum: No registered users and 1 guest