How to fix 3D Mono Sound Error [UPDATED]

Forum rules
SCS as a company do not wish to have paid mods on this forum. While we understand that not all paid mods use the Intellectual Property of other companies/people, it is very hard to moderate what is and isn't acceptable when money is involved. There are also concerns that it could look unfavorable to potential work partners going forward if SCS allow mods that may potentially use unlicensed branding.
Posting in the Mods forum (ATS and ETS2) is restricted to sharing free-to-the-public mods and providing support for mods. For more details, please check chapters [4] and [5] of Forum Rules.
Post Reply
User avatar
Mohammad
Posts: 2959
Joined: 12 Oct 2018 20:53
Location: Birmingham
Contact:

How to fix 3D Mono Sound Error [UPDATED]

#1 Post by Mohammad » 28 Dec 2019 20:27

28/12/19: TOBJ and DDS File Error: SOLVED

So I have a modded truck, but two of the .tobj and one of the .dds files cannot be read in read only mode.
It's a continuous error that is very annoying:

Code: Select all

00:05:22.535 : <ERROR> [fs] Failed to open file '/vehicle/truck/XXX/interior/textures/base/gaugelbl.tobj' in the read_only mode.
00:05:22.544 : <ERROR> [fs] Failed to open file '/vehicle/truck/XXX/interior/textures/base/m_details.tobj' in the read_only mode.
00:05:25.436 : <ERROR> [fs] Failed to open file '/vehicle/truck/XXX/interior/textures/base/m_details.dds' in the read_only mode.
00:05:25.436 : <ERROR> [dds] Can not load '/vehicle/truck/XXX/interior/textures/base/m_details.dds'
XXX being where the truck model/ it's interiors and where the .tobj and .dds files are placed.
I tried editing it in ATS Studio via opening it as people have said on the forum but it didn't work, I thought because the paths were correct but apparently not, double checked in HxD but they are still correct
I tried editing the dds by saving it as 512x512 and saving it as DXT5 without mip map but no luck.

It worked for two other .tobjs so why didn't it work with these two and how would I fix them and the .dds files?
______________________________________________________________________________________________________________________________________________________________________________________________________
30/12/2019: 3D Mono Sound Error: NOT SOLVED

So I fixed the previous error, but now I added @kriechbaum's Cummins Big Cam/ NTC / 275 from the Scot A2HD
However I keep getting this error:

Code: Select all

01:59:53.257 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
01:59:53.258 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
01:59:53.258 : <ERROR> [ds8] Buffer size: 2908944 [0x80070057]
01:59:53.258 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
01:59:56.403 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
01:59:56.403 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
01:59:56.404 : <ERROR> [ds8] Buffer size: 966656 [0x80070057]
01:59:56.404 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
02:00:04.115 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
02:00:04.115 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
02:00:04.116 : <ERROR> [ds8] Buffer size: 2039392 [0x80070057]
02:00:04.116 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
02:00:05.966 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
02:00:05.966 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
02:00:05.966 : <ERROR> [ds8] Buffer size: 1824256 [0x80070057]
02:00:05.966 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
02:00:07.067 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
02:00:07.068 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
02:00:07.068 : <ERROR> [ds8] Buffer size: 1784220 [0x80070057]
02:00:07.069 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
02:00:11.312 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
02:00:11.312 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
02:00:11.312 : <ERROR> [ds8] Buffer size: 1020072 [0x80070057]
02:00:11.313 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
02:00:11.320 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
02:00:11.320 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
02:00:11.320 : <ERROR> [ds8] Buffer size: 294924 [0x80070057]
02:00:11.321 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
02:00:14.493 : <ERROR> [ds8] Error creating sound buffer [0x80070057]
02:00:14.493 : <ERROR> [ds8] Source data format: 2 channels, 16 bits, 44100 Hz [0x80070057]
02:00:14.494 : <ERROR> [ds8] Buffer size: 829440 [0x80070057]
02:00:14.494 : <ERROR> [ds8] 3D sources require mono sound data! [0x80070057]
I'm not a sound expert so I don't know what causes this error, but how would I fix it?
Last edited by Mohammad on 30 Dec 2019 18:19, edited 5 times in total.
Image

User avatar
xXCARL1992Xx
Posts: 12629
Joined: 17 Aug 2016 12:18
Contact:

Re: How to fix .tobj and .dds files not read in read only mode.

#2 Post by xXCARL1992Xx » 28 Dec 2019 20:33

your def files, the game tells you it cant open the .tobj because there is none with this name in this folder
Image
| !!!NO SUPPORT OR REQUESTS OF ANY SORT VIA PM!!! | Screenshot Thread | Steam Workshop | World of Trucks Profil |

User avatar
Mohammad
Posts: 2959
Joined: 12 Oct 2018 20:53
Location: Birmingham
Contact:

Re: How to fix .tobj and .dds files not read in read only mode.

#3 Post by Mohammad » 28 Dec 2019 20:35

So how would I remove this error, deleting the files all together?.
Some parts of the truck have the no texture found, which could be the .dds file
Image

User avatar
xXCARL1992Xx
Posts: 12629
Joined: 17 Aug 2016 12:18
Contact:

Re: How to fix .tobj and .dds files not read in read only mode.

#4 Post by xXCARL1992Xx » 28 Dec 2019 20:41

correct the path in the materials
Image
| !!!NO SUPPORT OR REQUESTS OF ANY SORT VIA PM!!! | Screenshot Thread | Steam Workshop | World of Trucks Profil |

User avatar
Mohammad
Posts: 2959
Joined: 12 Oct 2018 20:53
Location: Birmingham
Contact:

Re: How to fix 3D Mono Sound Error [UPDATED]

#5 Post by Mohammad » 30 Dec 2019 18:16

That error is now fixed due to renaming and fixing it's path. Thanks @xXCARL1992Xx.

However I am getting a new sound error, details in first post...
Image

User avatar
Watermark
Posts: 483
Joined: 26 Nov 2013 22:16

Re: How to fix 3D Mono Sound Error [UPDATED]

#6 Post by Watermark » 30 Dec 2019 18:35

I also get randomly the audio error, all I do is exit and restart the game, which is fixing the problem, don't ask me why or what causes the error...

Post Reply

Return to “Modding Guides”

Who is online

Users browsing this forum: asana, faruk54 and 1 guest