AI swerve wildly when changing lanes

User avatar
Bandit & The Snowman
Posts: 877
Joined: 23 Oct 2014 15:55
Location: East Bound and Down
Contact:

AI swerve wildly when changing lanes

#1 Post by Bandit & The Snowman » 05 Mar 2017 20:56

At this place on I80, sometimes AI changing to the right lane after overtaking me do a wild swerve to the hard shoulder.
May have to reload traffic to observe this.
In the video I'm standing, but the first time happened while I was driving.

(sec-0024-0006);-95180.6;87.9658;-21178;-0.341616;-0.338086
Video
game log
Last edited by Bandit & The Snowman on 07 Mar 2017 12:04, edited 1 time in total.

User avatar
piva
Posts: 2018
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#2 Post by piva » 06 Mar 2017 00:49

I confirm, I saw it sometime, but I don't have video.
I just want to make a game and mods better.

User avatar
Loutis
SCS Software
Posts: 979
Joined: 23 Nov 2015 08:55
Location: Observable Universe

Re: AI swerve wildly when changing lanes

#3 Post by Loutis » 06 Mar 2017 13:12

I can't reproduce it in any way, do you have any clues how to reproduce it, coordinates to exact position would be great.
"I'm not trying to be anyone's savior. I'm just trying to think about the future and not be sad."
Elon Musk

Tesla & SpaceX fanboy. Carefully optimistic about Mars colonisation.

User avatar
airbus_sai
Beta tester
Posts: 590
Joined: 14 Jan 2013 17:15

Re: AI swerve wildly when changing lanes

#4 Post by airbus_sai » 06 Mar 2017 14:45

Loutis, isn't it 28474 ticket, but in reverse? Because there were two separate fixes, 19081 and 28474, and 19081 is now reverted.
Last edited by airbus_sai on 06 Mar 2017 14:53, edited 1 time in total.
"Now, I am become Death, the destroyer of squirrels."

User avatar
Bandit & The Snowman
Posts: 877
Joined: 23 Oct 2014 15:55
Location: East Bound and Down
Contact:

Re: AI swerve wildly when changing lanes

#5 Post by Bandit & The Snowman » 06 Mar 2017 14:48

Heigh-day, how could I.
(sec-0024-0006);-95180.6;87.9658;-21178;-0.341616;-0.338086

User avatar
Loutis
SCS Software
Posts: 979
Joined: 23 Nov 2015 08:55
Location: Observable Universe

Re: AI swerve wildly when changing lanes

#6 Post by Loutis » 06 Mar 2017 14:49

It might be similar, problem is that I need to be able to reproduce it to be able to actually make a sensible report :/

cheers, Ill take a look at it

EDIT: Nope, I can't reproduce it. Any ideas or extra info ?
"I'm not trying to be anyone's savior. I'm just trying to think about the future and not be sad."
Elon Musk

Tesla & SpaceX fanboy. Carefully optimistic about Mars colonisation.

User avatar
Moh1336
Beta tester
Posts: 7769
Joined: 05 Jul 2013 09:44
Location: Yorkshire
Contact:

Re: AI swerve wildly when changing lanes

#7 Post by Moh1336 » 06 Mar 2017 14:50

I haven't see this in ATS yet, but I did spot in in the closed beta for ETS2. It seems to be rare though, i've seen it only once.
My Blog/Mod page: http://ijsmods.wordpress.com
I reserve the right to be 100% wrong.
Image

User avatar
Reinhard
Posts: 2865
Joined: 20 Dec 2012 16:46
Location: Nimby, District of Berlin

Re: AI swerve wildly when changing lanes

#8 Post by Reinhard » 06 Mar 2017 14:55

Something like this happens if a road segment accidentally has the option "Left handed traffic" ticked. O not ticked, where it should (UK, ETS 2). Could easily be a simple error in the map.

User avatar
Moh1336
Beta tester
Posts: 7769
Joined: 05 Jul 2013 09:44
Location: Yorkshire
Contact:

Re: AI swerve wildly when changing lanes

#9 Post by Moh1336 » 06 Mar 2017 14:58

If it was that I would imagine all the AI would do it though. When I saw it happen there were four vehicles and only one of them jumped to the hard shoulder and back, the other three continued on their merry way as though nothing weird happened. :P
My Blog/Mod page: http://ijsmods.wordpress.com
I reserve the right to be 100% wrong.
Image

User avatar
Bandit & The Snowman
Posts: 877
Joined: 23 Oct 2014 15:55
Location: East Bound and Down
Contact:

Re: AI swerve wildly when changing lanes

#10 Post by Bandit & The Snowman » 06 Mar 2017 15:12

Exactly, and it only happens when they're going at 'cruise speed'; slow vehicles don't do it* (e.g. those that have just pulled out behind me), nor have I seen trucks do it.

*Maybe that's a hint? Could also be misleading, though.

Post Reply

Return to “Bugs 1.6”

Who is online

Users browsing this forum: No registered users and 1 guest