AI swerve wildly when changing lanes

User avatar
Reinhard
Posts: 2629
Joined: 20 Dec 2012 16:46
Location: Nimby, District of Berlin

Re: AI swerve wildly when changing lanes

#11 Post by Reinhard » 06 Mar 2017 15:26

Moh1336 wrote:When I saw it happen there were four vehicles and only one of them jumped to the hard shoulder and back, the other three continued on their merry way as though nothing weird happened.
On the same lane?

Some lanes could be unaffected by this. Lane layout is simply inverted, starting from the right instead from the left. If the distances match, a lane could be continued, or showing only a minor effect.

I have never seen such behavior in ETS 1/2 not caused by an error in a map mod. But of course this proves nothing. Could be easily decided if the exact location would be known.

User avatar
piva
Posts: 1685
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#12 Post by piva » 06 Mar 2017 16:16

I can't reproduce on my computer too, even I see it not a one time.
I see flying cars that fly away in the sky near Oxnard stupid tuckstop, but I haven't video. :lol:
Now I see some strange in trafic behavior in 1.6 - traffic became more stupid, with the same traffic_data.sii parameters what was working well in 1.5.
I know that it is bug, but I don't have facts to show you something. :roll:
I just want to make a game and mods better.

IonutL
Posts: 1076
Joined: 13 Apr 2014 20:16

Re: AI swerve wildly when changing lanes

#13 Post by IonutL » 06 Mar 2017 20:15

For the past 30 minutes, i tried to observe this bug and i just managed to saw it once, but it was pure luck.
I was parked outside the road on the grass for a couple of minutes already, when i decided that maybe it would need the truck to be in lane so the cars would change the lane in front of my truck. While trying to get on the road, there i saw it. After that nothing.
As you can see, pointed by the areas "encircled", the road doesn't have a smooth curvature. All vehicles, when passing through that segment, make a slight adjustment to their direction. My theory is that this bug can happen when it's necessary for a vehicle to change their lane right in that specific point. Now i don't know if the AI needs to overtake me, then go back to the first lane or only going from second lane to the first one.
Image

User avatar
Smarty
Beta tester
Posts: 1137
Joined: 30 Jun 2015 01:56
Location: Ontario, Canada
Contact:

Re: AI swerve wildly when changing lanes

#14 Post by Smarty » 06 Mar 2017 21:14

You can see several instances of jerky behaviour where that kink is in the first minute or so. The rest is just me being a dink trying to reproduce it. The trouble is the traffic starts to pile up and slow down after not too long...
(video still has ~15 minutes of upload to go...)

User avatar
Reinhard
Posts: 2629
Joined: 20 Dec 2012 16:46
Location: Nimby, District of Berlin

Re: AI swerve wildly when changing lanes

#15 Post by Reinhard » 06 Mar 2017 22:14

IonutL wrote:and i just managed to saw it once, but it was pure luck.
Reading this, I guess that my "left handed traffic" idea goes straight out of the window, then. Strange driving would happen all the time if this was the reason. Too bad, it would have been easy to solve.

I just tried the given coordinates and let the traffic flow a good while while using "warp 5". Could detect nothing unusual... Maybe I'm just lucky. It is not the first time that I've never encountered problems with the AI other people had.

User avatar
TarsoMagno
Beta tester
Posts: 1912
Joined: 04 Apr 2016 11:03
Location: Rio Grande do Norte - Brasil

Re: AI swerve wildly when changing lanes

#16 Post by TarsoMagno » 07 Mar 2017 11:22

Loutis it's the same i spotted on QA 36699


Some coords will help me to reproduce.

EDIT: nevermind i saw the coords on previous page

User avatar
pigbrother
Posts: 266
Joined: 03 Jun 2016 07:36
Location: Romania
Contact:

Re: AI swerve wildly when changing lanes

#17 Post by pigbrother » 14 Mar 2017 06:04

Any news about this problem? Because it happened to me twice, one time in ATS on top of the Tejon Pass and one time in ETS2 near the tunnel between Geneve and Bern and if this is a map problem, not a general AI one, probably more coordinates would help debugging and I should file a bug report.

User avatar
piva
Posts: 1685
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#18 Post by piva » 15 Mar 2017 11:07

Problem not fixed in 1.6.0.10 and ETS2 same problem too.

Now begin jumping trucks :lol:
On I-80 saw twice jumping trucks accross lanes.
Last edited by piva on 15 Mar 2017 11:08, edited 1 time in total.
I just want to make a game and mods better.

User avatar
Loutis
SCS Software
Posts: 964
Joined: 23 Nov 2015 08:55
Location: Observable Universe

Re: AI swerve wildly when changing lanes

#19 Post by Loutis » 15 Mar 2017 13:50

I was still unable to witness the issue sadly.

No idea how to reproduce it since any hint you gave me did not help.
"I'm not trying to be anyone's savior. I'm just trying to think about the future and not be sad."
Elon Musk

Tesla & SpaceX fanboy. Carefully optimistic about Mars colonisation.

User avatar
piva
Posts: 1685
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#20 Post by piva » 15 Mar 2017 15:02

Increate traffic density (maybe by mod), drive on I-80 and you see it. I don't know another solution.

EDIT. It's look like overtaking maneuver finished action give this issue, so I saw it when cars or trucks overtake me and when they must be rearranged to the right lane, this problem appear bit not every time, this is a big problem to find not permanent error.
I don't know another explanations. I'll hope that I can help you. If you have a queston, please ask.
I just want to make a game and mods better.

Post Reply

Return to “Bugs 1.6”

Who is online

Users browsing this forum: No registered users and 1 guest