AI swerve wildly when changing lanes

User avatar
Bandit & The Snowman
Posts: 933
Joined: 23 Oct 2014 15:55
Location: East Bound and Down
Contact:

Re: AI swerve wildly when changing lanes

#21 Post by Bandit & The Snowman » 15 Mar 2017 15:27

Artificially changed conditions a.k.a. Mods are not desirable for analyzing bugs :)
I can reproduce it at the coordinates I gave. When I saw it for the first time, I was driving normally. To recreate the situation, I just place the truck on the right lane and reload until it happens (resetting traffic is enough). It makes no sense to wait for it, at least I have only seen it within 10-20 seconds from reloading.
Last edited by Bandit & The Snowman on 15 Mar 2017 16:26, edited 1 time in total.

User avatar
piva
Posts: 2286
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#22 Post by piva » 15 Mar 2017 16:05

I don't tell about, what mod staff may use, they can make own CLEAN mod for find this problem, no more else.
I just want to make a game and mods better.

User avatar
Bandit & The Snowman
Posts: 933
Joined: 23 Oct 2014 15:55
Location: East Bound and Down
Contact:

Re: AI swerve wildly when changing lanes

#23 Post by Bandit & The Snowman » 15 Mar 2017 16:38

I had another look at it and most of the time the first two AI after reloading do the swerve. The AI that follow are too slow mostly because of lane changes behind me.
It looks like two highway sections aren't stitched together correctly where the middle road marker has a bad transition. Also the side stripe takes a slight detour to the right.

User avatar
Loutis
SCS Software
Posts: 983
Joined: 23 Nov 2015 08:55
Location: Observable Universe

Re: AI swerve wildly when changing lanes

#24 Post by Loutis » 15 Mar 2017 16:55

You see I use our internal version where I can do whatever I want with all sorts of parameters in the game including traffic, time and whatnot.

Point is, I can't reproduce it in internal version whatever I do. That might mean that I will have to try it on Steam version of Open Beta.
If it is there as you say, that would mean that it is either fixed or caused by something else entirely.

I'll take a look at it.
"I'm not trying to be anyone's savior. I'm just trying to think about the future and not be sad."
Elon Musk

Tesla & SpaceX fanboy. Carefully optimistic about Mars colonisation.

User avatar
piva
Posts: 2286
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#25 Post by piva » 15 Mar 2017 17:24

You have a lot of beta testers, maybe they can help you.
I don't know another way to reproduce this problem.
I saw it when drive in game in ATS and ETS2 too.
I just want to make a game and mods better.

heroictrucker
Posts: 93
Joined: 20 Dec 2012 19:45

Re: AI swerve wildly when changing lanes

#26 Post by heroictrucker » 16 Mar 2017 03:22

Wasn't this done like back in ETS 2

With the Ali behavior

I've rember it correct

The Ali was in the right lane

Slowing or passing the traffic

Cause this bug sound like it before

User avatar
piva
Posts: 2286
Joined: 29 Oct 2014 16:41

Re: AI swerve wildly when changing lanes

#27 Post by piva » 16 Mar 2017 03:50

Game version 1.6.0.11
I drove over 1500 miles by I-10,I-5 and I-80 and don't see that issue, I don't say that it was fixed, but I don't see it.
I just want to make a game and mods better.

User avatar
Smarty
Beta tester
Posts: 1328
Joined: 30 Jun 2015 01:56
Location: Ontario, Canada
Contact:

Re: AI swerve wildly when changing lanes

#28 Post by Smarty » 16 Mar 2017 19:53

Afaik, this was specifically marked fixed in today's update 1.6.0.12.

Post Reply

Return to “Bugs 1.6”

Who is online

Users browsing this forum: No registered users and 2 guests