dx11 keeps crash [MOD]

Post Reply
Magraina
Posts: 4
Joined: 25 Dec 2019 19:10
Location: Germany

dx11 keeps crash [MOD]

#1 Post by Magraina » 25 Dec 2019 20:26

Hey there,
my game keeps crashing every few minutes (5~30 min), with the actual game version (1.36.1.34s). So it is reproducible for me.
errors in the log are always the same:

Code: Select all

 <ERROR> [dx11] error creating render target view
<ERROR> [dx11] meta_copy: failed to create SRV (0x887a0005)
....
<ERROR> [dx11] Failed to create texture (/vehicle/xxxx/xxxx/xxxx.xxx) (0x887a0005)
latest logs are attached:
game.log.txt
(83.4 KiB) Downloaded 34 times
game.crash.txt
(86.41 KiB) Downloaded 18 times
I've disabled every Mod to make sure the issue comes from the game itself.
I've updated all my Drivers and reinstall my grafik driver with default settings.
My windows 10 64bit is also up to date.

I would be thankful for any help!

Friendly Regards

User avatar
BK Vissers
Global moderator
Posts: 14653
Joined: 05 Nov 2016 16:02
Location: Canada
Contact:

Re: dx11 keeps crash

#2 Post by BK Vissers » 25 Dec 2019 23:07

You sure you disabled all mods?

Realistic Graphics Mod - by Frkn64
DP's Realistic Traffic RST

Seem to mount but not unmount.

This error is caused by a texture not being Dx11 compatible. Specifically the one for Bushnell Farms. As thats an SCS one, if there was a problem with it then we’d have thousands of similar reports. What is likely is something that replaced the Bushnell texture ( like a real company or real traffic mod) is the source of the issue.
Image

Magraina
Posts: 4
Joined: 25 Dec 2019 19:10
Location: Germany

Re: dx11 keeps crash

#3 Post by Magraina » 26 Dec 2019 05:15

Of curse I have disabled these mods!

They we're always mounted in the log, as long as they are subscribed in the workshop.
I've tested this.
So if they are mounted and this means they are loaded, so this theory make sense, even though they are disabled. But this would also mean disable function did not work.
But I have tested a lot and I have found out that before I load my savegame the Mods are mounted by ModManager.
And if there are Mods activated when I load a savegame, they would be mounted again after the entry "New profile selected: 'xxxx' ". That means for me they are only loaded if they are activated.

latest mod I've used is "DP's Realistic Traffic RST". I've disabled all other mods long ago cause of these problems which I had since dx11 is in the game (1.35).
If I activate a Mod like this Traffic Mod the error happens even more often (probably I think because the problematic objects appears earlier).
Even though this mod is already updated an there are also no reports since months (quite apart from the fact that this mod does not change textures).
I also check these mods and no one of them contains a texture named like these in the log

User avatar
Mohegan13
Global moderator
Posts: 19786
Joined: 05 Jul 2013 09:44
Location: West Yorkshire; Mars
Contact:

Re: dx11 keeps crash

#4 Post by Mohegan13 » 26 Dec 2019 09:14

Your GPU is struggling with DX11 for some reason. Make sure your drivers are up to date, failing that you might want to considering clearing out the drivers completely using DDU and reinstall the latest.
Image
I reserve the right to be 100% wrong.
But on my tombstone when I go, just put 'death by rock and roll'.

Magraina
Posts: 4
Joined: 25 Dec 2019 19:10
Location: Germany

Re: dx11 keeps crash

#5 Post by Magraina » 26 Dec 2019 13:34

I told you that i've done that already :(
I've checked all my drivers, not only the graphic driver.
I use actual Geforce driver 441.66
I also reinstall the game.

Yesterday my game keeps crashing very often every 5-10min, but then the game runs for hours. The only thing I have been done, was driving out of California to Utah.
That's the first time since 1.35 that the game runs that long without crashing.

But if you mean to me I should do that this way, I will give it another try with DDU.

User avatar
Andre_AW
Beta tester
Posts: 1531
Joined: 24 Aug 2016 14:00
Location: Brazil

Re: dx11 keeps crash

#6 Post by Andre_AW » 26 Dec 2019 21:13

@Magraina follow some of these steps and see if it works

on steam, start the game in safe mode (your game will start the graphics at a minimum), then change to your normal settings.
ImageImage

Magraina
Posts: 4
Joined: 25 Dec 2019 19:10
Location: Germany

Re: dx11 keeps crash

#7 Post by Magraina » 27 Dec 2019 12:10

Actual I have tested a lot as I described.
I also deleted the cache in the savegame folder (maybe there is something wrong cached; I don't know).
Then after I've done a lot of things it runs for me for hours without any crash as I described at my last post.
Yesterday I also reinstall the graphic driver using DDU although it currently works.
Also I was driving back to California where I had at least these problems, but everything is actual just fine.
So on I go back and I tried to use a traffic mod. Finally with no problems. I'm Happy :D

So I think my problem is solved, but I don't know what was wrong or rather I don't know what finally solve this problem.
Thanks for any help!

User avatar
plykkegaard
Posts: 4449
Joined: 26 Oct 2014 13:42
Location: Denmark
Contact:

Re: dx11 keeps crash

#8 Post by plykkegaard » 30 Dec 2019 19:16

Same issue in my case probably a faulty GPU as mentioned
Funny thing is it only happens in ATS not in ETS2
ATS have never seen a mod, ETS2 has been modded but mods are disabled atm
Office moved to Fort Collins, Colorado

Jodir
Posts: 10
Joined: 27 Feb 2020 05:02

Re: dx11 keeps crash [MOD]

#9 Post by Jodir » 24 Jul 2020 15:52

Hello!

I have had this same problem since ets2 started using DX11 in version 1.36.

We've updated gpu drivers, formatted the computer, removed mods, but nothing has been resolved.

It became impossible to play because the strokes are constant.

In other games, they have no problem, even those with DX11. This problem only occurs in ETS2 and ATS.

Here, on other people's forums, the problem is reported, but with no apparent solution.

Problem for AMD and Nvidia Gpus.

> Sorry, Google Translate.

Post Reply

Return to “Bugs 1.36”

Who is online

Users browsing this forum: No registered users and 2 guests