[Announcement] 01.06.2021 : New FORUM RULES announced! Please familiarize with them.

Stuttering with own trailer

barry
Posts: 99
Joined: 31 Oct 2013 08:42

Re: Stuttering with own trailer

#91 Post by barry » 17 May 2021 07:31

Hi guys. I usually use Promods with a 'High' DEF file as i get > 120 f.p.s going through a 144Mhz Gsync monitor in cities, but for the purposes of testing this morning i used a 'Standard Draw Distance' Promods DEF file. It went back to stutters and pausing. So -for me at least- Promods is on the back burner. I only play single player mode.

Regards

User avatar
BackboneOne
Posts: 22
Joined: 24 Apr 2020 11:54

Re: Stuttering with own trailer

#92 Post by BackboneOne » 17 May 2021 08:14

barry wrote:
16 May 2021 23:05
it never occured to me that Promods would be the cause of any problems on my system.
:shock: awesome find! i wonder if promods devs knows about it..

hoevenvd
Posts: 59
Joined: 02 Jan 2021 11:43
Location: The Netherlands

Re: Stuttering with own trailer

#93 Post by hoevenvd » 17 May 2021 08:20

barry wrote:
17 May 2021 07:31
Hi guys. I usually use Promods with a 'High' DEF file as i get > 120 f.p.s going through a 144Mhz Gsync monitor in cities, but for the purposes of testing this morning i used a 'Standard Draw Distance' Promods DEF file. It went back to stutters and pausing. So -for me at least- Promods is on the back burner. I only play single player mode.

Regards
I currently use a 'LOW' DEF-file, that gives me stutters. I will test a 'HIGH' DEF-file. That will give me FPS-drops I assume, but will be a good test-case to see if it stops the stuttering. As I understand from your comment that you have no stuttering when using the HIGH DEF-file, right?

User avatar
Madkine
Global moderator
Posts: 4897
Joined: 08 Oct 2018 16:35
Location: Australia
Contact:

Re: Stuttering with own trailer

#94 Post by Madkine » 17 May 2021 08:51

No, he gets stuttering with both. He was hoping the low def file might remove the stuttering.

hoevenvd
Posts: 59
Joined: 02 Jan 2021 11:43
Location: The Netherlands

Re: Stuttering with own trailer

#95 Post by hoevenvd » 17 May 2021 09:00

Okay, as I thought that "but for the purposes of testing this morning i used a 'Standard Draw Distance' Promods DEF file. It went back to stutters and pausing." means that stuttering re-appered because of the phrase "went back to stutters and pausing"

@barry What other DEF-options do you have, regarding 'Special Transport' and 'other map combinations'?

barry
Posts: 99
Joined: 31 Oct 2013 08:42

Re: Stuttering with own trailer

#96 Post by barry » 17 May 2021 09:43

Hi. As a matter of habit i always chose the 2 options of other map and special transport combinations as i used to use both. I stopped using the additional Russian map because i usually became late with deliveries due to the border paperwork checking -which i don't think is factored into the delivery time. Anyway. yes when i stopped using Promods all stutering/pausing problems dissapeared, it was when our friend 'paulieGTR' mentioned about the posibility of people using a DEF file that was too much for their system specs that i tried the standard draw distance instead of my usual high draw distance. I admit the micro stuttering was hardly noticable, but the >=1 second pausing remained withh the lower DEF file.

The pausing i am experiancing with Promods is not due to hard drive access, because it doesn't occur in the standard SCS maps, but it's rather like someone pressing and releasing a pause button. If i'm cornering like going onto or off of a highway access/exit ramp at the time of a pause, my logitech steering wheel jumps in my hands because the time difference of where i was, to where i am after the pause has moved during the pause duration, It's not a true pause in the sense of all operations stop and restart, the game is still progressing but the display freezes - i hope you can understand how i'm trying to explain the problem :(

I'll certainly try the low draw distance DEF file and also without the other map and special transport. I'll post back with my findings.

I feel i must apoligie to SCS as this thread now appears to be focusing on a 3rd party problem and not a V1.40 bug per-se.

Regards

hoevenvd
Posts: 59
Joined: 02 Jan 2021 11:43
Location: The Netherlands

Re: Stuttering with own trailer

#97 Post by hoevenvd » 17 May 2021 10:23

I understand what you mean while turning the wheel and the game continues :) And to be fair, I dont think anyone in this thread accused/blamed SCS for this issue. @Max also dropped by some pages back. For me, I also had this stuttering in vanilla maps (1.39 and 1.40) and single play, and that specific situation -for me- I solved myself by changing r_page_buffer_size and fixed the refresh rate at 50Hz. There was no promods involved in this one.

I created a DEF file, settings ultra, no Special Transport, no other map combinations. And so far, with this DEF, I did already made a stutter-free trip of 500km in north of Sweden (Promods-territory). Knock, knock on wood

I will continue testing, and let you know. As I am sure that SCS is also interested in happy stutter-free people :D

barry
Posts: 99
Joined: 31 Oct 2013 08:42

Re: Stuttering with own trailer

#98 Post by barry » 17 May 2021 11:52

Hi. Some short testing >=500KM only ProMods installed. No other maps or traffic etc.

Promods Def High, Standard, Low = Pausing
Promods Def with no other maps or Special Transports = Pausing.

There is seemingly no pattern to the frequency of the pausing, neither speed nor surroundings - it is particulaly annoying when it happens whilst going round a roundabout - whether in a city or countryside scenario. On my system the pausing is >=1 second (approx) in duration, and in the testing duration > 10 pauses. I tried g_traffic "0.1" upto g_traffic "3.0" and there is no change in the pausing duration or frequency. As ths is -for me- only happening when ProMods is installed, i wonder if the game constantly checks the whole map integrity while the user is driving, and -i'm thinking outside the box here- perhaps runs out of time before completing it's task, hence the pausing.

I really don't know what else to try now. It's a definate for me that Promods is the problem. AMD Ryzen 3600/ 16GB ram, Nvidia RTX 2080, 144 Mhz monitor and typical framerate >100 f.p.s at all times should be enough to not induce any untoward problems.
Oh well, time for a cup of tea.

Regards

hoevenvd
Posts: 59
Joined: 02 Jan 2021 11:43
Location: The Netherlands

Re: Stuttering with own trailer

#99 Post by hoevenvd » 17 May 2021 12:50

Same.

DEF Low, map combinations, Special Transport => stutter
DEF Ultra, no map combinations, no Special Transport => stutter
DEF Ultra, no map combinations, Special Transport => stutter

I am also out of options, but -just like @barry- stuttering is now isolated around Promods Single Play. Promods Multiplay goes well, so does all vanilla combinations. I think I can get used to drive a in-game trailer on Promods Single Play, and use my beautiful own trailer ( :D ) on multiplay...

How about other people in this topic? Also stuttering on promods single play, and other combination goes well? In that case, moderator might close this bug-topic.... (?)

Orsa1305
Posts: 8
Joined: 29 Mar 2021 12:35

Re: Stuttering with own trailer

#100 Post by Orsa1305 » 17 May 2021 15:08

I made a new profile, with all my standard mods, but no promods and no hired drivers, using my owned trailer from lvl 5, now lvl 17 and no horrible stutter, just some minor ones, even so minor that i'm not really sure it happened lol.

Post Reply

Return to “Bugs 1.40”

Who is online

Users browsing this forum: No registered users and 2 guests