SCS General Discussion Thread

The forum dedicated to site issues, problems and wishes.
Truckdrivr
Posts: 48
Joined: 07 Feb 2021 10:04

Re: SCS General Discussion Thread

#4731 Post by Truckdrivr » 10 Apr 2021 12:08

it sounds like alot are expericing what is called "rubber-banding" or "frog-effect"? if so in the global config.file find this line:

uset t_averaging_window_length "xxx"

"xxx" is replaced by number, the value has to be double of what hz you run the game in, if 60 hz then the type value of 120. default is 20.

all thanks to the guys at Roextended forum https://roextended.ro/forum/viewtopic.p ... 158#p25158 (link goes into a deeper explanation on this subject)
i have used this fix for over a year and have absolute zero stutters or rubber-banding, no matter how detailed the area i travel is and no matter if i use own-trailer or not. Try and see if it works, it only take 30 seconds.

edit: cleared up my words abit.
Last edited by Truckdrivr on 10 Apr 2021 12:15, edited 5 times in total.

User avatar
krmarci
Posts: 1165
Joined: 03 Jul 2015 17:33
Location: Hungary
Contact:

Re: SCS General Discussion Thread

#4732 Post by krmarci » 10 Apr 2021 12:09

My only problem right now is memory. I have 8 GB RAM, of which 70% is used under normal conditions (i.e. not running anything). Getting 32 GB on Tuesday, let's hope that'll be enough... :-D

User avatar
Esproquet
Posts: 851
Joined: 18 Mar 2020 11:04
Location: N-301 [➕] N-340

Re: SCS General Discussion Thread

#4733 Post by Esproquet » 10 Apr 2021 12:15

I 've only experienced important stutters on Thursday, in Valencia & Barcelona. Yesterday it was mostly OK (not perfect though).

I suffer them in cabin view when I move the camera left & right. External cam gives me 100% fps no matter how much I play with the camera angle.
IBERIA screenshots interactive map: https://maphub.net/Esproquet/ets2-iberia

User avatar
B787
Posts: 3979
Joined: 10 Aug 2017 17:08
Location: Germany

Re: SCS General Discussion Thread

#4734 Post by B787 » 10 Apr 2021 12:28

I changed the value to 120 but it doesn't change anything.
Stutters when moving inside is the same for me. But only when turning right to the passenger side. Turning left is smooth.

Truckdrivr
Posts: 48
Joined: 07 Feb 2021 10:04

Re: SCS General Discussion Thread

#4735 Post by Truckdrivr » 10 Apr 2021 12:31

i dont know if u use any start parameters in steam, but i use these also maybe they will help you? https://roextended.ro/forum/viewtopic.p ... lit=rubber

-64bit -nointro -unlimitedlog -mm_pool_size 4000 -mm_max_resource_size 32 -mm_max_tmp_buffers_size 1000

edit: cleared up my writing

wato
Posts: 76
Joined: 06 Jul 2020 11:24

Re: SCS General Discussion Thread

#4736 Post by wato » 10 Apr 2021 12:55

Truckdrivr wrote:
10 Apr 2021 12:08
it sounds like alot are expericing what is called "rubber-banding" or "frog-effect"? if so in the global config.file find this line:

uset t_averaging_window_length "xxx"

"xxx" is replaced by number, the value has to be double of what hz you run the game in, if 60 hz then the type value of 120. default is 20.

all thanks to the guys at Roextended forum https://roextended.ro/forum/viewtopic.p ... 158#p25158 (link goes into a deeper explanation on this subject)
i have used this fix for over a year and have absolute zero stutters or rubber-banding, no matter how detailed the area i travel is and no matter if i use own-trailer or not. Try and see if it works, it only take 30 seconds.

edit: cleared up my words abit.
Just to add to this for people with G-Sync/Free-sync monitors and compatible graphics cards. Set t_averaging_window_length to 1, enable G-Sync/Free-sync, and disable V-sync.

Game runs really smooth for me since I found out about these settings. Used to get bad rubber-banding and generally lower fps before with the default setting.

NB. I also use these launch options (pool_size := half RAM):

Code: Select all

-mm_max_tmp_buffers_size 1000 -mm_pool_size 16384

User avatar
Holzauge
Posts: 842
Joined: 28 Aug 2016 13:33
Location: Republica de las Patatas

Re: SCS General Discussion Thread

#4737 Post by Holzauge » 10 Apr 2021 13:03

I had stutters in ATS around Boise. "Fortunately" the HD broke (system drive already was a SSD) and I exchanged it with a SSD. No - mentionable - stutters anymore. And no, no stutter problems in Iberia (yet).

User avatar
Mohegan13
Global moderator
Posts: 20230
Joined: 05 Jul 2013 09:44
Location: West Yorkshire; Mars
Contact:

Re: SCS General Discussion Thread

#4738 Post by Mohegan13 » 10 Apr 2021 13:20

Truckdrivr wrote:
10 Apr 2021 12:31
-64bit -nointro -unlimitedlog -mm_pool_size 4000 -mm_max_resource_size 32 -mm_max_tmp_buffers_size 1000
-64bit is not needed as the game is only 64big now anyway.

-unlimitedlog is not needed unless you are having mod issues and the log is being truncated. Without issues, you can play for over 6hrs and the log limit likely won't be reached. ;)
Image
I reserve the right to be 100% wrong.
But on my tombstone when I go, just put 'death by rock and roll'.

User avatar
Bandit & The Snowman
Posts: 2503
Joined: 23 Oct 2014 15:55
Location: East Bound and Down
Contact:

Re: SCS General Discussion Thread

#4739 Post by Bandit & The Snowman » 10 Apr 2021 13:36

To shorten things a little, in this thread viewtopic.php?f=41&t=261451 there some more hints for optimization re: stutters etc. This is not just for high-end machines.

Some newbie driver
Posts: 5398
Joined: 12 Dec 2018 11:37

Re: SCS General Discussion Thread

#4740 Post by Some newbie driver » 10 Apr 2021 13:43

Anyways, stutters it's just the consequence one's computer can't keep a smooth amount of FPS. The reasons behind that consequence are as many as different computers we have. So, there exist no magical and universal solution (if any from our side; sometimes the reason is nothing we can change).

Not to mention the important subjective perception component there's on an stutter problem. Some people has a really thin skin with them while other couldn't care less.

Post Reply

Return to “SCS Site”

Who is online

Users browsing this forum: Quark and 16 guests