FMOD Discussion [ETS2]

User avatar
cip
Posts: 5932
Joined: 26 Aug 2016 08:14
Location: Brussels

Re: FMOD Discussion [ETS2]

#371 Post by cip » 14 Aug 2020 11:38

I will also disappear for a week at the end of August because we move to a new apartment ;)
meantime I have my music at menu working but I have a bigger issue now, FMOD is cutting off my truck engine sound when there is high traffic and sounds around (only in ETS2) :evil:
Enjoy driving with my Real Traffic Density for ETS2 and ATS
Enjoy listening my ATS Real Ai Traffic Sounds 1.36-1.37
currently on strike :D beta testings and bug reports are temporarily suspended from my activity until further decisions :lol:

User avatar
Robinicus
Posts: 2332
Joined: 26 Aug 2018 13:02

Re: FMOD Discussion [ETS2]

#372 Post by Robinicus » 14 Aug 2020 14:49

I really haven't been doing much of anything with FMOD either....just generally frustrated with the lack of engagement in simple tasks (like updating data on the wiki) by SCS
MS Flight Sim 2020 - Alpha test team - Whoot! We finally moved to closed beta in prep for August 18th release!

Don't PM me for FMOD help, ask on the forum so others can learn from it as well

My sound work is only for friends from now on

User avatar
snare85
Posts: 51
Joined: 05 Nov 2016 01:53
Location: Russia, Vladivostok

Re: FMOD Discussion [ETS2]

#373 Post by snare85 » 16 Aug 2020 11:53

xXCARL1992Xx wrote:
09 Aug 2020 18:15
i tried my luck again and converted EVRs MP3 sound and used the new Pete template as reference for the automations, so far it sound really good, better then my MAN and New Scania converts so far, question is, how can i minimize the "over revving" when the truck is shifting, particularly in lower gears when the truck changes into the next gear it sound like it revs higher and goes down right after, i looked at the Pete template and didnt saw any significant difference that would give me an idea how to solve it
Hi, do I understand correctly, here you need to choose the correct values for "pich" and " autopitch"

User avatar
snare85
Posts: 51
Joined: 05 Nov 2016 01:53
Location: Russia, Vladivostok

Re: FMOD Discussion [ETS2]

#374 Post by snare85 » 16 Aug 2020 13:06

@Drive Safely - I would try build it like the timeline sheet for engine start and stop with the fueling sound fully contained in the loop portion; similar to how I built the horns. You can often figure out how long of a sample to use for these type of sounds by ripping apart the SCS banks.

Image
[/quote]

Hi Robinicus, can I find out more about these conditions?
Today I ran into a problem, I can't stop Horn, or it only play it once. Version ETS 2 1.38, FMOD 2.01.03.
Everything worked in the previous version.

User avatar
Rockeropasiempre
Posts: 657
Joined: 21 Jun 2016 05:10

Re: FMOD Discussion [ETS2]

#375 Post by Rockeropasiempre » 16 Aug 2020 17:54

@snare85

See that you have well routed on your correct route. It happened to me with some engines, that after exiting the truck and returning to the game options, the engine sound continued to play.
Image Image

Always soft

User avatar
snare85
Posts: 51
Joined: 05 Nov 2016 01:53
Location: Russia, Vladivostok

Re: FMOD Discussion [ETS2]

#376 Post by snare85 » 17 Aug 2020 13:26

quote=Rockeropasiempre, thanks, i I double checked this moment.
But no.
Attachments
2.png
1.png
Last edited by supersobes on 17 Aug 2020 15:04, edited 1 time in total.
Reason: Removed quote [Forum rule 2.12]

johnny244
Posts: 3
Joined: 16 Aug 2020 07:06

Re: FMOD Discussion [ETS2]

#377 Post by johnny244 » 17 Aug 2020 14:41

Hi everyone, there is a problem i am trying to solve.
I have a soundset of whirring sounds of the engine and they are intend to only be heard inside the cabin. So far my result has been great ingame when the camera is inside the cabin. However, the soundset is, as expected, also audible in exterior views. Is there a way to make them only audible in interior views. Thanks.

User avatar
Дорожный рассвет
Posts: 613
Joined: 19 Dec 2016 05:31
Location: Украина

Re: FMOD Discussion [ETS2]

#378 Post by Дорожный рассвет » 18 Aug 2020 04:45

The most unsuccessful patches for the entire time are 1.37-1.38, since the game has a new sound engine and at the same time there are no interior sounds and no turbo sounds, I don't want to play this game anymore.

User avatar
Max2712
Posts: 100
Joined: 14 Oct 2016 23:02
Location: Saxony, Germany

Re: FMOD Discussion [ETS2]

#379 Post by Max2712 » 18 Aug 2020 15:04

Hey everyone, I´ve done a new sound mod for the NG Scania I6 engines and I am actually pretty satisfied with it, except one thing: It seems that FMOD or the game plays a sound sample multiple times at once if the revs go over the same area really fast, for example while accelerating and shifting up or while revving the engine without gear. I have used SCS´ 1.38 template for it and of course the 2.01.01 version of FMOD. I can´t find any errors or missing things in the project, but this bug is really annoying me. I´ve also shot a little video demonstrating this bug: https://www.youtube.com/watch?v=5PsQvDOVDh8 You can hear it the best between 3:50 and 4:40, where I first rev the engine and then let the engine run with constant revs. You can here how one sample after the other shuts off and how the engine is going to be quieter with the same amount of revs. Does someone know what the problem could be?

Thanks in advance!

User avatar
snare85
Posts: 51
Joined: 05 Nov 2016 01:53
Location: Russia, Vladivostok

Re: FMOD Discussion [ETS2]

#380 Post by snare85 » 19 Aug 2020 16:17

Max2712 wrote:
18 Aug 2020 15:04
Hey everyone, I´ve done a new sound mod for the NG Scania I6 engines and I am actually pretty satisfied with it, except one thing: It seems that FMOD or the game plays a sound sample multiple times at once if the revs go over the same area really fast, for example while accelerating and shifting up or while revving the engine without gear. I have used SCS´ 1.38 template for it and of course the 2.01.01 version of FMOD. I can´t find any errors or missing things in the project, but this bug is really annoying me. I´ve also shot a little video demonstrating this bug: https://www.youtube.com/watch?v=5PsQvDOVDh8 You can hear it the best between 3:50 and 4:40, where I first rev the engine and then let the engine run with constant revs. You can here how one sample after the other shuts off and how the engine is going to be quieter with the same amount of revs. Does someone know what the problem could be?

Thanks in advance!
I didn't understand anything( what are you talking about?

Post Reply

Return to “General discussion about the game”

Who is online

Users browsing this forum: No registered users and 10 guests