Oculus Rift - experimental support

OriginalBeezer
Posts: 1
Joined: 10 Jun 2017 10:37

Re: Oculus Rift - experimental support

#561 Post by OriginalBeezer » 10 Jun 2017 10:38

Agreed. I had it running beautifully smooth last night but after today's update we are jittery as.

edited to add: I am now also experiencing the same problem in AT.... its as if I can no longer turn off ASW, so I get that judder at all graphics settings :(

And edited again: issue resolved. I'm not sure why but my anti virus was apparently causing my terrible fps and juddering. Uninstalled and back to smooth trucking. This is my first week with the oculus and its the best thing I've ever bought. There's no way I will ever go back non-vr simming.

User avatar
Komat
SCS Software
Posts: 624
Joined: 26 Nov 2012 09:22

Re: Oculus Rift - experimental support

#562 Post by Komat » 12 Jun 2017 08:25

TheHire99 wrote:
10 Jun 2017 01:49
Is anyone having an issue with a rubber banding like effect since the update
This effect is caused by ASW toggling between the 45Hz and 90Hz mode. Either disable ASW or force it to always run at 45Hz

glojo
Posts: 2
Joined: 25 Nov 2014 22:32

Re: Oculus Rift - experimental support

#563 Post by glojo » 14 Jun 2017 17:55

Hi,
I tried driving today in American Trucker whilst wearing my Vive and I cannot, cannot get the view out of what I will describe as 'Cinema' mode. In other words I can see the game but it is on what looks like a cinema screen and it is not in a VR mode.

I have opened the game in steam, I am using the latest Occulous\Vive patch. I have added -openvr in the correct location and unticked that box referring to theatre mode... Help!!

The Vive works perfectly in all other games, just not the two truck driving simulators :(

Uxot
Posts: 270
Joined: 20 Jun 2013 00:52

Re: Oculus Rift - experimental support

#564 Post by Uxot » 14 Jun 2017 18:50

Komat wrote:
12 Jun 2017 08:25
TheHire99 wrote:
10 Jun 2017 01:49
Is anyone having an issue with a rubber banding like effect since the update
This effect is caused by ASW toggling between the 45Hz and 90Hz mode. Either disable ASW or force it to always run at 45Hz
Where i change any settings of this? with -occulus in config theres none of this..but with -openvr theres seems to be options about this? :S


Well i added " o_oculus_independent_timewarp "0 - 1" in console and i didnt see any change on the judder :/

mahoon
Posts: 2
Joined: 29 Feb 2016 08:19

Re: Oculus Rift - experimental support

#565 Post by mahoon » 15 Jun 2017 12:38

I use oculus debugging tool to set ASW to off. The tool is in '\Program Files\Oculus\Support\oculus-diagnostics' I find also turning off the Adaptive GPU performance scale helps keeps things smooth too.
Last edited by Centrino2 on 15 Jun 2017 14:53, edited 1 time in total.
Reason: Read Forum Rules

Uxot
Posts: 270
Joined: 20 Jun 2013 00:52

Re: Oculus Rift - experimental support

#566 Post by Uxot » 15 Jun 2017 22:11

mahoon wrote:
15 Jun 2017 12:38
I use oculus debugging tool to set ASW to off. The tool is in '\Program Files\Oculus\Support\oculus-diagnostics' I find also turning off the Adaptive GPU performance scale helps keeps things smooth too.
Well i guess im curse or something...

i tried all the ASW settings and it changed NOTHING,Adaptive GPU performance scale = off resets to default when i close if i keep open i see no changes in-game..

I dont get why ATS and CV1 wont work with -openvr command...it was so smooth on my DK2 with ultra settings no judder or anything...with -oculus i can barely put medium and i get judders :/

User avatar
EarthMover
Posts: 61
Joined: 19 Jan 2017 19:04
Location: Finland

Re: Oculus Rift - experimental support

#567 Post by EarthMover » 16 Jun 2017 08:48

Another one with problems after latest update. Fps IS screwed, no matter what settings i tried with asw etc. it stays unplayable. Before update it was running very nicely, only biggest towns i had some stuttering. While i love ets2 and oculus i think I'm giving up with this game, it's just too annoying when you never know If it's going to run or not when you start the game next Time.
CPU: Intel Core i7-2600k @3.40GHz | Motherboard: Asus P8P67-M | Memory: Kingston 16GB DDR3 | OS W10 | GPU: Sapphire R9 290x 8GBDDR5 | Devices: Oculus Rift CV1, Logitech G27, Almar Scania SKRS shifter, Gametrix Jetseat

tallguy
Posts: 22
Joined: 16 Aug 2014 07:19

Re: Oculus Rift - experimental support

#568 Post by tallguy » 21 Jun 2017 10:52

TL;DR So..as far as I've read (not everything with 57 pages ;) ) I understand that using an Oculus will work in EST2.
I have to add the -oculus paramater after the executable, or in my case...in Steam.

To check if I have it right:
1. It will work with ETS2
2. I have to add the -oculus paramter
3. I have to have SteamVR???
4. I can continue playing with my current ETS2 including the profile?

Am I correct with these or am I missing something? I play the game vanilla as far as the map goes (no 3rd party maps), only mods.

Hope to hear from you.

User avatar
EarthMover
Posts: 61
Joined: 19 Jan 2017 19:04
Location: Finland

Re: Oculus Rift - experimental support

#569 Post by EarthMover » 22 Jun 2017 13:20

EarthMover wrote:
16 Jun 2017 08:48
Another one with problems after latest update. ----.
Allrighty, feelin pretty stupid now...it has nothing to do with update, totally my own fault. Last time i was playing it i was on photo mode without oculus, so i was set all graphics to Max, scaling to 400% etc. So that was The reason for crappy frame rate :oops: D'oh! Sure i hope game will be optimized further but at least it's fully playable again. :)
CPU: Intel Core i7-2600k @3.40GHz | Motherboard: Asus P8P67-M | Memory: Kingston 16GB DDR3 | OS W10 | GPU: Sapphire R9 290x 8GBDDR5 | Devices: Oculus Rift CV1, Logitech G27, Almar Scania SKRS shifter, Gametrix Jetseat

User avatar
EarthMover
Posts: 61
Joined: 19 Jan 2017 19:04
Location: Finland

Re: Oculus Rift - experimental support

#570 Post by EarthMover » 22 Jun 2017 13:22

tallguy wrote:
21 Jun 2017 10:52
TL;DR So..as far as I've read (not everything with 57 pages ;) ) I understand that using an Oculus will work in EST2.
I have to add the -oculus paramater after the executable, or in my case...in Steam.

To check if I have it right:
1. It will work with ETS2
2. I have to add the -oculus paramter
3. I have to have SteamVR???
4. I can continue playing with my current ETS2 including the profile?

Am I correct with these or am I missing something? I play the game vanilla as far as the map goes (no 3rd party maps), only mods.

Hope to hear from you.
Hello there!

1.yes
2.yes
3.not necessary, it works fine without it too.
4.yes.

Cheers!
CPU: Intel Core i7-2600k @3.40GHz | Motherboard: Asus P8P67-M | Memory: Kingston 16GB DDR3 | OS W10 | GPU: Sapphire R9 290x 8GBDDR5 | Devices: Oculus Rift CV1, Logitech G27, Almar Scania SKRS shifter, Gametrix Jetseat

Post Reply

Return to “General discussion about game”

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests