Euro Truck Simulator 2 - Steam has stopped working

Post Reply
x9navysteve
Posts: 1
Joined: 19 Jun 2013 23:06

Euro Truck Simulator 2 - Steam has stopped working

#1 Post by x9navysteve » 19 Jun 2013 23:28

Hello all,

I was wondering if you guys could help me figure out what is causing my Euro Truck Simulator to stop working. Any advice would be much appreciated!

System Specs:
Windows Vista
Intel Core i7-2600 3.4ghz CPU
8GB Memory
NVIDIA GeForce GT 440 w/ 1.5gb Memory

Problem Description:
I own a copy of ETS2 on Steam. I cannot say what caused this problem to start. I have been playing this game for months without problems. I last loaded the game successfully about 8 hours ago and played. I closed it as normal and now, when I start the game, it plays the SCS Software introduction screen for about 3 seconds before crashing and popping up a window that says "Euro Truck Simulator 2 - Steam has Stopped Working" then closes the game. During that time, I did not install any new hardware or software and no system update was run. I just had the computer sitting in the office as I normally do. I have not installed any mods to the base game. I tried a clean reboot of my system and ran the game again, with the same result. I uninstalled the game, then reinstalled it and that didn't solve the problem. Using the Steam options, I also tried loading the game using the "Launch with DX," "Launch with OpenGL," and "Launch in Safe Mode" options with the same issue each time.

I don't know if this problem has to do with Steam or with ETS2, but all of my other Steam games are working properly at this time. I appreciate any help that anyone can give me.

Game Log File
************ : log created on : Wednesday June 19 2013 @ 16:31:45
00:00:00.000 : [sys] running on x86 / Windows Vista x64 (version 6.0)
00:00:00.000 : [sys] DirectX version : 4.09.00.0904
00:00:00.000 : [cpu] GenuineIntel [ Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz] 8 logical processor(s) at ~3392MHz.
00:00:00.000 : [sys] Using 2 worker thread(s)
00:00:00.000 : [sys] using QPC / TSC invariant timer, frequency 3312832Hz
00:00:00.000 : [mem] physical memory total: 8173MiB
00:00:00.000 : [mem] physical memory avail: 5868MiB
00:00:00.000 : [mem] virtual memory total: 4095MiB
00:00:00.000 : [mem] virtual memory avail: 3945MiB
00:00:00.000 : [mem] Trying to allocate memory pool (204800K)
00:00:00.008 : Disabling color wrap as both color strings are empty
00:00:00.036 : [hashfs] base.scs: Mounted and validated, 35008 entries (77EC69F462FB36FD267857072B63E5DB3E1031FB73E78ED3DF0B348D4221BF7)
00:00:00.061 : [hashfs] def.scs: Mounted and validated, 2410 entries (A8C23B55F6D9C020B85678B63CAF312E20EC32B64DE96F0079CFD1BD76127E9)
00:00:00.098 : [hashfs] locale.scs: Mounted and validated, 108 entries (D336F504D3D989B93E9B6A489451AEC7E80A208962319C3268DA653EB6EDF95)
00:00:00.099 : [hashfs] base_cfg.scs: Mounted and validated, 2 entries (726DC946A70E16A5E040DC7E9E90F83D6153D76B255B8E02B7EE61E055FAB23)
00:00:00.099 : [ufs] Home directory: 'C:/Users/Steve/Documents/Euro Truck Simulator 2'.
00:00:00.099 : exec /home/config.cfg
00:00:00.099 : [sys] Executing /home/config.cfg ...
00:00:00.099 : uset r_full_resolution_corrections "0"
00:00:00.099 : uset r_force_color_shadowmaps "0"
00:00:00.099 : uset g_hw_info "1"
00:00:00.099 : uset g_cargo_sort "2"
00:00:00.100 : uset g_tooltip_delay "0.4"
00:00:00.100 : uset g_desktop_fadeout "60"
00:00:00.100 : uset r_segment_cache_static_buffers "1"
00:00:00.100 : uset r_segment_cache_behavior "3"
00:00:00.100 : uset r_use_depth_bounds "1"
00:00:00.100 : uset r_show_light_pixel_coverage "0"
00:00:00.100 : uset r_mirror_scale_y "1"
00:00:00.100 : uset r_mirror_scale_x "1"
00:00:00.100 : uset r_scale_y "0.75"
00:00:00.100 : uset r_scale_x "0.75"
00:00:00.100 : uset r_sunshafts "0"
00:00:00.100 : uset r_color_saturation "1.0"
00:00:00.100 : uset r_color_yellow_blue "0.0"
00:00:00.100 : uset r_color_magenta_green "0.0"
00:00:00.100 : uset r_color_cyan_red "0.0"
00:00:00.100 : uset r_color_correction "0"
00:00:00.100 : uset r_dof_filter_size "0.5"
00:00:00.100 : uset r_dof_transition "400.0"
00:00:00.100 : uset r_dof_start "200.0"
00:00:00.100 : uset r_dof "0"
00:00:00.100 : uset r_mlaa_threshold "1.0"
00:00:00.100 : uset r_mlaa "0"
00:00:00.100 : uset r_hdr "0"
00:00:00.100 : uset r_fake_shadows "1"
00:00:00.100 : uset r_sun_shadow_texture_size "2048"
00:00:00.100 : uset r_sun_shadow_quality "0"
00:00:00.100 : uset r_mirror_view_distance "80"
00:00:00.100 : uset r_deferred_mirrors "0"
00:00:00.100 : uset r_deferred "1"
00:00:00.100 : uset r_startup_progress "0"
00:00:00.100 : uset r_setup_done "1"
00:00:00.100 : uset r_gamma "1.0"
00:00:00.100 : uset r_nv_stereo_mode "2"
00:00:00.100 : uset r_no_frame_tracking "0"
00:00:00.100 : uset r_msaa "0"
00:00:00.100 : uset r_fullscreen "0"
00:00:00.100 : uset r_mode "1280x1024x32x0"
00:00:00.100 : uset r_path ""
00:00:00.100 : uset r_device "dx9"
00:00:00.100 : uset g_trackir "1"
00:00:00.100 : uset g_pedestrian "0"
00:00:00.100 : uset g_light_span_factor "0"
00:00:00.100 : uset g_light_distance_factor "0"
00:00:00.100 : uset g_vehicle_flare_lights "0"
00:00:00.100 : uset g_auto_traffic_headlights "0"
00:00:00.100 : uset g_auto_traffic "1"
00:00:00.100 : uset g_kdop_preview "0"
00:00:00.100 : uset g_screenshot_on_bug "0"
00:00:00.100 : uset g_developer "0"
00:00:00.100 : uset g_wc_fps "0.0"
00:00:00.100 : uset g_wc_radius "-1.0"
00:00:00.100 : uset g_flyspeed "100.0"
00:00:00.101 : uset g_news "1"
00:00:00.101 : uset g_colbox "0"
00:00:00.101 : uset g_radio_mode "1"
00:00:00.101 : uset g_ignore_low_fps "0"
00:00:00.101 : uset g_truck_light_quality "1"
00:00:00.101 : uset g_truck_light_specular "1"
00:00:00.101 : uset g_gfx_all_scales "0"
00:00:00.101 : uset g_gfx_advanced "0"
00:00:00.101 : uset g_gfx_quality "-1"
00:00:00.101 : uset g_menu_aa_limit "8"
00:00:00.101 : uset g_additional_water_fov "20.0f"
00:00:00.101 : uset g_rain_reflect_hookups "0"
00:00:00.101 : uset g_rain_reflect_actor "0"
00:00:00.101 : uset g_rain_reflect_traffic "0"
00:00:00.101 : uset g_rain_reflect_cache "0"
00:00:00.101 : uset g_rain_reflection "0"
00:00:00.101 : uset g_reflection "0"
00:00:00.101 : uset g_grass_density "0"
00:00:00.101 : uset g_veg_detail "0"
00:00:00.101 : uset g_minicon "0"
00:00:00.101 : uset g_console "0"
00:00:00.101 : uset g_texture_usage_stats "0"
00:00:00.101 : uset g_fps "0"
00:00:00.101 : uset g_stream_exts ".ogg;.mp3"
00:00:00.101 : uset r_vsync "1"
00:00:00.101 : uset r_anisotropy_factor "0"
00:00:00.101 : uset r_texture_detail "2"
00:00:00.101 : uset t_averaging_window_length "20"
00:00:00.105 : [lang] Language autodetection: 409
00:00:00.112 : Selected language: en_gb
00:00:00.112 : Euro Truck Simulator 2 init ver.1.3.1s (rev. 43709)
00:00:00.112 : [net] LOG INFO: Started
00:00:00.118 : Setting UI reference mode to: 1440x900...
00:00:00.118 : [gfx] Selected rendering device: dx9
00:00:00.127 : [dx9] NVAPI initialized
00:00:00.154 : [dx9] Direct3D9Ex detected.
00:00:00.154 : [dx9] Number of adapters found: 1
00:00:00.198 : [dx9] Adapter #0: NVIDIA GeForce GT 440 / 1535 MB (nvd3dum.dll, 8.17.13.142, 20120515)
00:00:00.198 : [dx9] Using SM3X rendering path
00:00:00.198 : [gfx] Trying to set 1280x1024 32bpp (windowed)
00:00:00.211 : [dx9] SLI not found.
00:00:00.211 : [dx9] Stereo fully allowed.
00:00:00.211 : <ERROR> [dx9] Stereo enable query failed: 4294967156
00:00:00.211 : [dx9] D3D9 device sucessfully created [HWVP]
00:00:00.291 : Game viewport set to: (window aspect ratio=1.25); viewport bounds=[left=0.00 right=1280.00 bottom=112.00 top=912.00]
00:00:00.311 : [al] device: OpenAL Soft
00:00:00.311 : [al] context extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_loopback
00:00:00.350 : [al] vendor: OpenAL Community
00:00:00.350 : [al] version: 1.1 ALSOFT 1.14
00:00:00.350 : [al] renderer: OpenAL Soft
00:00:00.350 : [al] extensions: AL_EXT_ALAW AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFTX_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points
00:00:00.350 : [snd] Started sound update thread
00:00:00.357 : [di8] Initializing device '@@keyboard@@' as 'keyboard'
00:00:00.359 : [di8] Initializing device '@@mouse@@' as 'mouse'
00:00:00.391 : [TrackIR] Device initialized. TrackIR software version 5.00.
00:00:00.415 : dispatch
00:00:00.415 : exit
Game Crash File
-----------------------------------------
Crash log created on: Wed Jun 19 16:26:47 2013
Build: 1.3.1s 43709
OS: x86 / Windows Vista x64 (version 6.0)
CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz at 3392000
MEM: Phys:8173 Virt:4095
GPU: NVIDIA GeForce GT 440 Mem:1535 Ver: 8.17.13.142(20
Exception code: C0000005 ACCESS_VIOLATION
Fault address: 380C7880 DEAD:BEEF0002

Registers:
EAX:00000102
EBX:04560000
ECX:769814D0
EDX:00000000
ESI:01CE6D44
EDI:04705550
CS:EIP: 0023:380C7880
SS:ESP: 002B:06A8FCA8 EBP:06A8FF80
DS:002B ES:002B FS:0053 GS:002B
Flags: 00010246
EIP preamble: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
EIP bytecode: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

Call stack:
Address Frame
380C7880 00000000 DEAD:BEEF0002


Stack:
01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80 69 67 FF FF FF FF FF 02 01 00 00 14 FC A8 06 00 00 00 00 C4 FF A8 06 F0 6F 9A 76 36 47 3F 60
FE FF FF FF D0 14 98 76 94 11 50 75 F4 01 00 00 E8 03 00 00 00 00 00 00 44 6D CE 01 98 FC A8 06
48 11 50 75 F4 01 00 00 E8 03 00 00 00 00 00 00 80 FF A8 06 80 78 0C 38 F4 01 00 00 E8 03 00 00
> 00 00 00 00 00 00 00 00 50 55 70 04 64 00 66 00 BC FC A8 06 5C 00 44 00 65 00 76 00 69 00 63 00
65 00 5C 00 48 00 61 00 72 00 64 00 64 00 69 00 73 00 6B 00 56 00 6F 00 6C 00 75 00 6D 00 65 00
33 00 5C 00 57 00 69 00 6E 00 64 00 6F 00 77 00 73 00 5C 00 53 00 79 00 73 00 74 00 65 00 6D 00
33 00 32 00 5C 00 63 00 73 00 72 00 73 00 73 00 2E 00 65 00 78 00 65 00 00 00 00 00 2F 00 01 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 7F 02 00 00 00 00 00 00
FF FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 2B 00 00 00 53 00 00 00 2B 00 00 00 2B 00 00 00 00 00 00 00 00 00 00 00
50 55 70 04 00 00 00 00 00 00 00 00 40 7A 0C 38 00 00 00 00 B4 01 38 77 23 00 00 00 02 02 00 00
F0 FF A8 06 2B 00 00 00 7F 02 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80 1F 00 00 FF FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
-Steve

User avatar
Komat
SCS Software
Posts: 596
Joined: 26 Nov 2012 09:22

Re: Euro Truck Simulator 2 - Steam has stopped working

#2 Post by Komat » 20 Jun 2013 08:13

This is caused by the beta version of the Steam client. You need to opt-out of the beta until Valve fixes that.

Edit: It seems that they already fixed the client.

Post Reply

Return to “Technical Problems”

Who is online

Users browsing this forum: No registered users and 1 guest