Forum bug: cannot load SCS General Discussion Thread

The forum dedicated to site issues, problems and wishes.
User avatar
plykkegaard
Posts: 4926
Joined: 26 Oct 2014 13:42
Location: Denmark
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#11 Post by plykkegaard » 24 Nov 2020 18:14

SQL error probably due to web server timeout resulting in an incomplete request

Code: Select all

SQL ERROR [ mysqli ]
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 5 [1064]
An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.
Office moved to Fort Collins, Colorado

Some newbie driver
Posts: 5019
Joined: 12 Dec 2018 11:37

Re: Forum bug: cannot load SCS General Discussion Thread

#12 Post by Some newbie driver » 24 Nov 2020 19:14

That's the SQL error people had been seeing all that afternoon

Funny thing, it says it's an SQL syntax problem (obviously not, the code of the forum hasn't changed on the moment of that error regarding the moment it works). But also, if it happens when you are posting a new message, the message itself is published correctly (or at least, 2 times happened that to me)

User avatar
plykkegaard
Posts: 4926
Joined: 26 Oct 2014 13:42
Location: Denmark
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#13 Post by plykkegaard » 24 Nov 2020 19:45

Me too
I assume the thread hangs when the page tries to reload
Office moved to Fort Collins, Colorado

User avatar
plykkegaard
Posts: 4926
Joined: 26 Oct 2014 13:42
Location: Denmark
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#14 Post by plykkegaard » 24 Nov 2020 22:30

It will be reported as a bug on the phpbb forum tomorrow

It is a really bad practice and a security risk to show errors from the backend, use at least a generic message and let the system do internal logging and create reports to the administrators

I assume the forum is not heavily modded, it does not seem to be on the public side I can view
Office moved to Fort Collins, Colorado

Some newbie driver
Posts: 5019
Joined: 12 Dec 2018 11:37

Re: Forum bug: cannot load SCS General Discussion Thread

#15 Post by Some newbie driver » 24 Nov 2020 22:48

As far as I remember, Timmy doesn't like to tinker too much (by itself or using addons) on the forum. He rather want the stability of a well know supported base version than the shine of cool thinks that end broken or unsupported time later. So, yes, not heavily modded for sure; not on our public view neither on the insides.

User avatar
bobgrey1997
Posts: 3781
Joined: 30 Nov 2015 02:13
Location: Conway, Arkansas
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#16 Post by bobgrey1997 » 25 Nov 2020 01:02

Not sure if this is related or not, but many times when I create a new post anywhere on the Forum, I get this page when I hit Submit:
Image

[EDIT] It actually just happened while submitting this post. One detail to add: when I press "Back" to get back to the Forum, my post I was attempting to submit does submit just fine.
ImageImage

User avatar
Marcello Julio
Posts: 3430
Joined: 12 Nov 2016 19:27
Location: Ceará, Brazil

Re: Forum bug: cannot load SCS General Discussion Thread

#17 Post by Marcello Julio » 25 Nov 2020 01:20

I can confirm this! The same is happening to me from time to time. It started to happen today after the overload at the time of the Wyoming teaser.

User avatar
supersobes
Global moderator
Posts: 12223
Joined: 07 Dec 2016 21:53
Location: Northern Virginia, USA
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#18 Post by supersobes » 25 Nov 2020 01:27

A similar SQL error has been happening to me for months on some random occasions when I try to approve a post in the Moderator Control Panel. Similar to what is happening where the message still gets posted when a user gets the error, the post still gets approved when the error occurs, but the action does not get logged in the moderator log, meaning we've had to notate those actions manually for our records. Apart from happening randomly on occasion, it also happens 100% of the time if I try to approve two posts in the same thread without first clicking out of the thread to another page.

Image

User avatar
bobgrey1997
Posts: 3781
Joined: 30 Nov 2015 02:13
Location: Conway, Arkansas
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#19 Post by bobgrey1997 » 25 Nov 2020 01:29

For me, this has happened on all but two of my posts today.
Well, make that three.
ImageImage

User avatar
abasstreppas
Posts: 8450
Joined: 06 Feb 2013 20:32
Location: On an island outside another island, outside another island...
Contact:

Re: Forum bug: cannot load SCS General Discussion Thread

#20 Post by abasstreppas » 25 Nov 2020 01:39

Count me in

It worked now tho
Image

Locked

Return to “SCS Site”

Who is online

Users browsing this forum: No registered users and 4 guests