<ERROR> [dx9] Present failed. [0x88760874]

gggp
Posts: 37
Joined: 25 Dec 2012 23:27

<ERROR> [dx9] Present failed. [0x88760874]

#1 Post by gggp » 09 Nov 2017 18:28

Posting this here in hopes it doesnt get deleted .

im getting that since i started playing newmexico , after every delivery completion and clicking drive to go back to the game world im getting a 10000% guaranteed black screen

i already sent 3 reports to scs and hopefully posting this here can help others having it seeing it started happening after new mexico update

with mods
without mods
old profile
new profile

windows 10 x64 same drivers and hardware since beta 1.29 started at any rate .

User avatar
Mohegan13
Beta tester
Posts: 19024
Joined: 05 Jul 2013 09:44
Location: West Yorkshire; Mars
Contact:

Re: <ERROR> [dx9] Present failed. [0x88760874]

#2 Post by Mohegan13 » 09 Nov 2017 18:47

https://steamcommunity.com/app/227300/d ... 121997957/

Maybe of use to you. It's related to your GPU in some way or another though.
Image
I reserve the right to be 100% wrong.
But on my tombstone when I go, just put 'death by rock and roll'.

gggp
Posts: 37
Joined: 25 Dec 2012 23:27

Re: <ERROR> [dx9] Present failed. [0x88760874]

#3 Post by gggp » 09 Nov 2017 18:51

thanks, ill see if that is of any use to my case...rather strange that this error started now..no other game had it and im playing scs games for a loong time....no errors of this so far very odd.

User avatar
Braakie
Posts: 784
Joined: 14 Feb 2016 21:23
Location: Holland
Contact:

Re: <ERROR> [dx9] Present failed. [0x88760874]

#4 Post by Braakie » 09 Nov 2017 20:21

II also had this, even with my new i7 8700K and GTX 1080 system. I forgot that I had configured nvidia profile inspector for ets2. After I switched off, it did not bother me anymore.

gggp
Posts: 37
Joined: 25 Dec 2012 23:27

Re: <ERROR> [dx9] Present failed. [0x88760874]

#5 Post by gggp » 09 Nov 2017 20:49

Braakie wrote:
09 Nov 2017 20:21
II also had this, even with my new i7 8700K and GTX 1080 system. I forgot that I had configured nvidia profile inspector for ets2. After I switched off, it did not bother me anymore.
Yes iv been searching them forums...this one and steam...no solutions apply for my case thing is its happening after completing the delivery and spending points in the profile ( after leveling up )

I had to start a new profile old one was ctd and the new one i created before purchasing NM today ctd'd aswell LOL ...no mods because im teting to see if it still crashes with stock game...

ANyway thanks for the suggestion does not apply for me...currently im using an amd r9 380 4gb vram...no issue whatsoever with the game at all..apart from that terrible error after NM dlc released..sigh

User avatar
Reinhard
Posts: 4905
Joined: 20 Dec 2012 16:46
Location: Nimby, District of Berlin

Re: <ERROR> [dx9] Present failed. [0x88760874]

#6 Post by Reinhard » 09 Nov 2017 21:14

Braakie wrote:
09 Nov 2017 20:21
II also had this, even with my new i7 8700K and GTX 1080 system. I forgot that I had configured nvidia profile inspector for ets2. After I switched off, it did not bother me anymore.
This error message is a generic one, I don't think it will reveal any real cause in any case. It just means that the game isn't able to communicate with the DX9 graphics subsystem anymore. Why? Probably, because the driver died. Question is: suicide, or murder?

This can have many different reasons, including hardware problems, driver version problems, whatever. Yes, these things can happen out of a sudden, and yes, it can totally happen that only one game is affected and others are doing well, but the came is still innocent. The internet is full of "it does only happen to game X, so it must be the fault of X" messages.

Nothing can be even guessed until a log of a faulty run is presented. It will probably don't reveal the cause either, but at least may show some interesting background information. Like driver version, CPU, available RAM. And if it is only that other experienced AMD users can comment the used driver version.

coalrollerlbz
Posts: 7
Joined: 04 Sep 2017 16:10

Re: <ERROR> [dx9] Present failed. [0x88760874]

#7 Post by coalrollerlbz » 09 Nov 2017 22:49

I'm having a similar issue whenever I go into the map or do anything in the "menu" if I try to hit Escape or click Drive my game freezes on the transition and my mouse freezes as well sometimes I have control of my vehicle and I can hear my game audio clear as day but the picture is still frozen have no idea what this means I've taken my mods out so it shouldn't be an issue with that. . Just posting to see if anyone else is experiencing this. .Thanks

gggp
Posts: 37
Joined: 25 Dec 2012 23:27

Re: <ERROR> [dx9] Present failed. [0x88760874]

#8 Post by gggp » 11 Nov 2017 00:23

@coalrollerlbz , exactly ever since new mexico ( and mostly in new mexico world map area but not limited to ) dropped on steam and i installed it i started getting that error out of nowhere, the game ran flawlessly before and even after ats launched i havent had such catastrophic issue ( 1.28 ) but in 1.29 update and new mexico release it started to occur... there is no way im able to tell whats causing it im playing many other games nothign does that , its all on scs to debug i cant do a thing about it i dont think anyone but them devs can.

I have on steam installed and playing not actively but every week or day depending on my mood...
darkest dungeon
ats
borderlands 2
brigador
xcom 2 woth jsut played 4 custom skirmishes/matches today because i got bored of ats crashing after every damn delivery...= 0 issues
sunless skies
fallout 4 heavly moded = 0 issues
transport fever ( this one is even not well optimized i had 0 issues )

i already submitted various detailed reports to support , all i can do is sit and wait for this to be fixed...
for others to KNOW im running the same hardware since 1.28 dropped...heck ever since ats launched in 2016...and i never had that issue with ANY game ever but since ats 1.29 launched the issue occurs only in ats .

cheers , signing out \.

User avatar
Mohegan13
Beta tester
Posts: 19024
Joined: 05 Jul 2013 09:44
Location: West Yorkshire; Mars
Contact:

Re: <ERROR> [dx9] Present failed. [0x88760874]

#9 Post by Mohegan13 » 11 Nov 2017 10:00

Try posting your full system specs. Maybe someone will be able to tell you the issue. A log wouldn't go a miss either.

There's really no point writing out a list of other games, because none of those games are this one. It's kind of like driving down the road and getting a flat tyre and saying "but this road doesn't make my other car's tyres go flat." ;)

Maybe the changes in 1.29/NM are just too much for your system to handle?

I'm assuming by now you have removed any software like NVIDIA Inspector that can cause issues, and updated your graphic drivers and Windows updates should there be any?
Image
I reserve the right to be 100% wrong.
But on my tombstone when I go, just put 'death by rock and roll'.

User avatar
TwistedLemon90
Posts: 70
Joined: 12 Jul 2017 17:31
Location: South Of I395
Contact:

Re: <ERROR> [dx9] Present failed. [0x88760874]

#10 Post by TwistedLemon90 » 12 Nov 2017 00:07

h4r4s3r wrote:
09 Nov 2017 18:28
Posting this here in hopes it doesnt get deleted .

im getting that since i started playing newmexico , after every delivery completion and clicking drive to go back to the game world im getting a 10000% guaranteed black screen

i already sent 3 reports to scs and hopefully posting this here can help others having it seeing it started happening after new mexico update

with mods
without mods
old profile
new profile

windows 10 x64 same drivers and hardware since beta 1.29 started at any rate .
Im having the same issue and i bought a garage in childress TX (C2C) but anyway im on an AMD System with DDR4 ram brand new everything pretty much and i get it just starting today pretty much never had an issue with it. Im just hoping SCS fixes it, i noticed ever since new mexico dropped everything started having some sort of issue but hey that's how it is, trial and error but my game log is filled with DX9 errors. Everything is up to date on my end. https://pastebin.com/dXi32TfA That's what he is talking about that was right after a delivery.

Post Reply

Return to “Technical Problems”

Who is online

Users browsing this forum: No registered users and 2 guests