1.35 Update makes wheel deadzone too big [87820]

Post Reply
sethtriggs
Posts: 29
Joined: 13 Dec 2015 07:41
Location: USA
Contact:

1.35 Update makes wheel deadzone too big [87820]

#1 Post by sethtriggs » 08 Jun 2019 16:46

I have an Thrustmaster NASCAR Pro Force Feedback wheel that I have used with ETS/ATS on Linux since I first bought the game, and it's worked perfectly up until the 1.35 update.

Unfortunately, since the update I have ended up with a very large deadzone. Whilst stopped, I can see the steering wheel and steer axles remain still for about a second while I am physically turning the wheel, and then it quickly turns outside of the deadzone.

This means the truck is controllable at low speeds (about 15km/h or so), but at any street-running speeds (30km/h and above), the truck is undrivable. Lane changes are all but impossible, and any sort of curve leads to an accident because it's not possible for the wheel to turn in time.

This has been working for years, and I do not know what in 1.35 could have broken things. I have never, ever used mods; I use a clean vanilla profile at all times.

Setting indications:
* The controller is detected within Steam and is detected in game as well, so it "works." All other functions are fine; brake and accelerator axes are fine.
* The first time I started ETS2 post-update there was an apparently garbled entry for the wheel controller that came up, indicating a conflict. I dismissed this and then went directly to the Input Wizard.
* In Options/Controls, the readout with the X-Axis is correct when I turn the wheel; it is centered and the yellow slider properly deflects all the way when I have the wheel turned in that direction.
* The Deadzone slider for the wheel axis (X) is completely to the left, which should make the deadzone minimum-size?
* The Steering Non-linearity slider is to the left as well.
* I disable force feedback because I was unsure of its support on Linux, plus it would require another plug in for those motors; my surge protector is already full.

Solutions I have tried, without benefit:
* Deleting and remapping the controls with the Control Wizard
* Adding the "-no_steam_subsys" launch option to start ETS2

I'm just tearing my hair out on this; the 1.35 update is so impressive to me with all the new features, but I am completely unable to complete a job! The first job I tried I had a spectacular wreck once I came up to one of the old single-lane interchanges and high-centered on the middle of the bridge!

Thanks in advance if any of you have any insights!

On edit: My settings,
[ external image ]

Game log follows:
game.log.txt
(38.63 KiB) Downloaded 47 times
Attachments
game.log.txt
Game Log I was able to grab from a drive with the truck
(38.63 KiB) Downloaded 42 times
Playing ETS/ATS on Linux Mint 21.2 (64 bit), AMD Ryzen 7 5700G with Radeon Graphics, 32GB DDR4 RAM
Tom
SCS Software
Posts: 1855
Joined: 03 Apr 2018 11:34

Re: 1.35 Update makes wheel deadzone too big [87820]

#2 Post by Tom » 10 Jun 2019 13:30

Thanks for report.
QA 87820
User avatar
Komat
SCS Software
Posts: 976
Joined: 26 Nov 2012 09:22

Re: 1.35 Update makes wheel deadzone too big [87820]

#3 Post by Komat » 10 Jun 2019 14:05

Your wheel returns large value of the flat parameter. You need to calibrate it.
sethtriggs
Posts: 29
Joined: 13 Dec 2015 07:41
Location: USA
Contact:

Re: 1.35 Update makes wheel deadzone too big [87820]

#4 Post by sethtriggs » 10 Jun 2019 15:05

Komat wrote: 10 Jun 2019 14:05 Your wheel returns large value of the flat parameter. You need to calibrate it.
I will try to do this when I get home; I am not sure if there is a utility to do it but I will check in Linux.

On the X-post of this that I made on Steam, another SCS developer recommended the JSCal utility; I will try this in a couple hours once I get home from work and I will do my best to document how it goes.
Playing ETS/ATS on Linux Mint 21.2 (64 bit), AMD Ryzen 7 5700G with Radeon Graphics, 32GB DDR4 RAM
sethtriggs
Posts: 29
Joined: 13 Dec 2015 07:41
Location: USA
Contact:

Re: 1.35 Update makes wheel deadzone too big [87820]

#5 Post by sethtriggs » 10 Jun 2019 22:00

The solution was effective!

First thing I discovered is I have the "joystick" package on Linux Mint, which includes evdev-joystick and jscal. I actually tried evdev-joystick just to see what happens because it gave deadzone information.

Code: Select all

Supported Absolute axes:
  Absolute axis 0x00 (0) (X Axis) (value: 0, min: -512, max: 511, flatness: 63 (=12.33%), fuzz: 3)
  Absolute axis 0x01 (1) (Y Axis) (value: 0, min: 0, max: 255, flatness: 15 (=5.88%), fuzz: 0)
  Absolute axis 0x02 (2) (Z Axis) (value: 0, min: 0, max: 255, flatness: 15 (=5.88%), fuzz: 0)
  Absolute axis 0x10 (16) (Hat zero, x axis) (value: 0, min: -1, max: 1, flatness: 0 (=0.00%), fuzz: 0)
  Absolute axis 0x11 (17) (Hat zero, y axis) (value: 0, min: -1, max: 1, flatness: 0 (=0.00%), fuzz: 0)
I ran the clear deadzones command.

Code: Select all

sudo evdev-joystick --e /dev/input/event6 --d 0

New dead zone value: 0
Trying to set all axes deadzone to: 0
  Absolute axis 0x00 (0) (X Axis) Setting deadzone value to : 0
    (value: 0, min: -512, max: 511, flatness: 0 (=0.00%), fuzz: 3)
  Absolute axis 0x01 (1) (Y Axis) Setting deadzone value to : 0
    (value: 0, min: 0, max: 255, flatness: 0 (=0.00%), fuzz: 0)
  Absolute axis 0x02 (2) (Z Axis) Setting deadzone value to : 0
    (value: 0, min: 0, max: 255, flatness: 0 (=0.00%), fuzz: 0)
  Absolute axis 0x10 (16) (Hat zero, x axis) Setting deadzone value to : 0
    (value: 0, min: -1, max: 1, flatness: 0 (=0.00%), fuzz: 0)
  Absolute axis 0x11 (17) (Hat zero, y axis) Setting deadzone value to : 0
    (value: 0, min: -1, max: 1, flatness: 0 (=0.00%), fuzz: 0)


I then booted ETS2 and did the test drive around Grimsby again. Success! I can control the truck properly.

Now I am going to set off and drive down to enjoy that new 1.35 territory! Sardinia or bust!

Thank you SCS, I am always glad to support ATS/ETS!
Playing ETS/ATS on Linux Mint 21.2 (64 bit), AMD Ryzen 7 5700G with Radeon Graphics, 32GB DDR4 RAM
sethtriggs
Posts: 29
Joined: 13 Dec 2015 07:41
Location: USA
Contact:

Re: 1.35 Update makes wheel deadzone too big [87820]

#6 Post by sethtriggs » 12 Jun 2019 22:00

I have an update in that because of the way Linux handles joystick devices now (as they're events now on Linux Mint), the calibration settings are lost each time. So each time on startup I invoke

Code: Select all

sudo evdev-joystick --evdev /dev/input/by-id/{controller name} --d 0 
...command.

I am not sure what is setting the flatness setting; knowing that ETS2 now gets this value, is there a way to always make the flatness 0 by default?

For those who have difficulty like this on Linux Mint, I accomplished this via using an entry in Menu/Preferences/Startup Applications; it will always run at startup and it can be set to work on delay.

When you run it on startup, you would just omit the "sudo" since Startup Applications run administratively.

Code: Select all

evdev-joystick --evdev /dev/input/by-id/{controller name} --d 0
Playing ETS/ATS on Linux Mint 21.2 (64 bit), AMD Ryzen 7 5700G with Radeon Graphics, 32GB DDR4 RAM
Post Reply

Return to “Technical Problems”

Who is online

Users browsing this forum: No registered users and 2 guests